PPTP WAN Issues



  • Hi,
    I have used pfsense 1.2.3 for years and i love it! It's a great product.
    One year ago i decided to upgrade my pfsense to 2.0 but since then i have problems to set my wan interface.

    I have to use the old pptp adsl way to connect to my internet provider and with pfsense 1.2.3 it worked a long time very well.

    But now with pfsense 2.0 i can't get traffic over my wan interface.
    I can ping websites, but any website do not load.
    The main problem is that every package on the wan interface get dropped.

    My settings are:
    10.0.0.138 is adress of my modem
    10.0.0.140 is adress of wan interface (em1)
    interface pptp1 is the ppp setup

    I tried all kind of allow rules (like GRE * * * * *) on the wan interface but all i get is:

    Block em1   10.0.0.138   10.0.0.140 GRE

    Block em1   10.0.0.138   10.0.0.140 GRE

    Block em1   10.0.0.138   10.0.0.140 GRE

    Block em1   10.0.0.138   10.0.0.140 GRE

    On the 2.0 version if i look at the /tmp/rules.debug file i see

    "interface WAN = "{ pptp1 }"

    Also i see the pass rule for this GRE traffic on my WAN interface
    pass in on $WAN proto gre from any to any keep state label "allow PPTP client on WAN"

    On the old pfsence 1.2.3 i also look at the /tmp/rules.debug file and i see

    "interface wan = "{ em1 pptp1 }"

    I am struggling with this for about months now again and i finally found some workaround.
    I changed the interface WAN from interface WAN = "{ pptp1 } to interface WAN = "{ pptp1 em1 }
    and reloaded the filtersettings manual with the command "pfctl -f /tmp/rules.debug"

    All websites load again and everything is fine, but everytime the filter reloads, the hardcoaded settings will be replaced by the
    default settings of /cf/conf/config.xml. So i have to do this workaround again and again.

    I hope someone of the pfsense team could fix this problem or anyone can solve it because there are a bunch of people who are frustraded with this bug.  :'(



  • Wrong forum if your using 2.0 release this is for 2.1 Dev only. :)



  • Anyone can help me pls?  :-\



  • push :)


Locked