Ntop 4.1.0_3 v2 no longer open



  • Hi all!

    pfSense 2.0.1-RELEASE (i386)
    built on Mon Dec 12 18:24:17 EST 2011
    FreeBSD 8.1-RELEASE-p6

    After updating ntop to version 4.1.0_3 v2, his page is no longer open. Writes, "the waiting time expired from the server."
    Reinstalling did not help.
    Before that everything worked well.

    Tell me what to do?



  • I've encountered the same problem with the newest nTop version.  Looking at netstat -an, I notice that the ntop service (3000) protocol is now at tcp6.  Previously it was on tcp4 and everything worked fine then…

    I found that the new nTop defaults to tcp6, so here is the workaround:

    Edit the file ntop.sh in /usr/local/etc/rc.d and add -4 to the parameter list of rc_start()

    Example:

    rc_start() {
           /usr/local/bin/ntop -i xl0 -u root -d -4 -M -x 8102 -X 8192
    &
    }

    Save the file and restart the nTop service.  Worked for me! ;)


  • Rebel Alliance Developer Netgate

    I just pushed an update to ntop to pass both -4 and -6 so it should latch onto both now.



  • Wow.  Thanks for that, sir! ;)

    Edit:

    After pushing the v2.1 update, the problem remains, sorry.  I had to remove -6 in the new ntop.sh file to get things working here.

    If both -4 and -6 are there, ntop still defaults listening to tcp6 only… :(

    ---snip---
    tcp6      0      0 *.3000                .                    LISTEN
    ---snip---



  • Hi friends!

    After reading the previous posts, I removed a tick in the position of "Track all traffic" (I have it was), in Diagnostics: ntop Settings, and it worked. :)
    Prior to that upgraded to the new version.



  • Rebel Alliance Developer Netgate

    I checked in a better fix that respects that option now. It should be OK no matter how that's set.



  • Hello Jimp,

    Tried v2.2 update and the problem persists…  :-[

    However, I also noted vladick0732's observation and everything runs fine now, except I do not have IPv6 traffic stats on the reports now (as expected).

    Thanks for the efforts! ;)



  • Still getting the issue as well

    4.1.0_3 v2.2

    can't access 3000, timed out.

    edit: i checked the file above

    Edit the file ntop.sh in /usr/local/etc/rc.d and add -4 to the parameter list of rc_start()
    heres what i have

    #!/bin/sh
    # This file was automatically generated
    # by the pfSense service handler.
    
    rc_start() {
    	/usr/local/bin/ntop -i em0 -u root -d -4 -6 -M -x 8102 -X 8192 &
    }
    
    rc_stop() {
    	/usr/bin/killall ntop
    }
    
    case $1 in
    	start)
    		rc_start
    		;;
    	stop)
    		rc_stop
    		;;
    	restart)
    		rc_stop
    		rc_start
    		;;
    esac
    
    

    reboot service and i do a netstat -an and i see this

    
    $ netstat -an
    Active Internet connections (including servers)
    Proto Recv-Q Send-Q  Local Address          Foreign Address       (state)
    tcp6       0      0 *.3000                 *.*                    LISTEN
    tcp6       0      0 *.53                   *.*                    LISTEN
    tcp4       0      0 *.53                   *.*                    LISTEN
    tcp4       0      0 *.80                   *.*                    LISTEN
    tcp4       0      0 *.443                  *.*                    LISTEN
    tcp4       0      0 *.22                   *.*                    LISTEN
    tcp6       0      0 *.22                   *.*                    LISTEN
    
    

    not sure why its not taking ipv4 on its listen interface. tried removing reinstalling the package


  • Rebel Alliance Developer Netgate

    Apparently because that makes it bind to ipv6 only… I removed that track option from the GUI in the new version and forced -4. It appears they broke their own options, so nothing we can do until ntop releases a fixed version. In the meantime using only -4 will make it listen as expected.

    It may not capture ipv6 traffic in that case (it might... haven't tried it) but it'll have to do for now.



  • Thanks jimp. I'll edit my rc.d file now and report back.

    I was the guy who asked to update to the latest earlier, sorry about causing headaches!


  • Rebel Alliance Developer Netgate

    It's ok, couldn't predict that they'd break it in this way. :-)



  • Works fine.

    I think like 1% of the world is using IPv6

    As a request, wouldn't it make sense to put the nTop in Diganostics to Status as nTop GUI

    Then have ntop settings in services?

    A little more neat and organized.


  • Rebel Alliance Developer Netgate

    We're pushing for ipv6 support in pfSense 2.1. The number of people using it is growing every day, so it's not something we can toss aside :-)

    Not sure about moving the menu entries around. Status does probably make more sense for both of them, or even services, but the case for Diagnostics is sort of there as well.



  • Hello jimp,

    I just pushed ntop v2.3 update today and all runs well now without extra tweaking, defaulted to tcp4 listening.  On the IP prefs, it indicates support for both IP v4 and v6.

    Thanks and have a nice day.  :)


Log in to reply