1.2-BETA-1-PRERELEASE-SNAPSHOT-04-21-07 refuses to update



  • When I try to update the firmware to a newer snapshot, all I get is an error message saying that The connection was reset, The connection to the server was reset while the page was loading, and nothing seems to happen as far as the firmware update goes. Is there any way to update short of reinstalling Pfsense?





  • What are the specs of the machine you are trying to update?  How much ram, disk space, etc?

    Embedded or full installation?



  • 1.6 Ghz P4 with 1.5 gigs of ram with 20 gigs of hard drive space (yes I know it's an overpowered system, but it was the only spare system I had) running a full installation from a CDrom

    EDIT: I think I'm just going to do a full reinstall of Pfsense, as for some reason Pfsense has filled the hard drive that I was using, which might explain a few of the quirks that I've been experiencing. So I figure I might as well stick in a larger hard drive to try and migitate that problem, thanks for the quick replies though.



  • Try upgrading from the shell.  Once it is updated try to feed the update to the firmware update page via the webConfigurator.

    I believe this problem is solved now and this will show us if it is.



  • I will test the April 23 snapshot's (I updated through reinstall a couple days ago) update feature when I return from a trip later this week and I will be sure to post here whether it was successful or not.



  • 1.2B1 is out now, don't use snapshots anymore unless told otherwise.



  • Yes, absolutely.  This cannot be said any more.  This is VERY important.

    DO NOT USE SNAPSHOTS AS THEY ARE PROVING GROUNDS FOR FUTURE FIXES BETWEEN VERSION (BETA VERSIONS).

    Sorry for the caps.



  • understood. I just updated to Beta1 and everything seems to be working perfectly. The only glitch was that the digital signature could not be verified. But that was a minor problem as I made sure to get the update file from your servers



  • @valunthar:

    understood. I just updated to Beta1 and everything seems to be working perfectly. The only glitch was that the digital signature could not be verified. But that was a minor problem as I made sure to get the update file from your servers

    That is normal.  Only I can sign updates and I don't really have the time to sit at the server every hour to sign new updates :)



  • what if you did run a recent snapshot and it is causing problems can you downgrade install snapshots???



  • No, its not recommended.  There are no known issues with recent snapshots.



  • well my users are moaning a lot lately that its slower
    and my one interface firewall gateway rules are not working at all???

    though i will try upgrade again and see what happens


Log in to reply