Tinydns (pkg dns-server) issues



  • When you first install tinydns, and you click on the "DNS Servers" menu item, you're sent to tinydns_status.php.  A warning is displayed:

    Warning: Invalid argument supplied for foreach() in /usr/local/www/tinydns_status.php on line 83

    The warning goes away once you start configuring Tinydns.

    The beginning of tinydns_status tries to determine if no settings are present and, in that case, direct you to the setup page, but it doesn't seem to work.

    =======

    Is tinydns_status.php supposed to show anything?  My page is totally blank.  At first, I thought tinydns_status only displayed data if you were load-balancing tinydns (based on http://www.pfsense.com/~sullrich/pics/tinydns_status.PNG).  But glancing at the code for the page, it looks like it's supposed to display some kind of status no matter what.

    My /service/tinydns/root/data file begins like:

    &example.com::ns.example.com
    Zexample.com:ns.example.com:postmaster.example.com
    @example.com::mail.example.com
    'example.com:v=spf1\040mx\040-all:86400
    =ns.example.com:1.2.3.4:86400
    +mail.example.com:1.2.3.4:86400
    +server.example.com:1.2.3.4:86400
    +www.example.com:1.2.3.4:86400

    I don't always explicitly associate IP addrs with hostnames in every single line of my data file.  Does tinydns_status.php expect me to do so?

    =======

    After you install tinydns (but before you've rebooted), tinydns doesn't seem to start itself after you begin adding entries.  "ps -auxw" showed no supervise, no svscan, no tinydns.  I probably could have kicked it off manually with /usr/local/bin/svscan /service, but I rebooted instead and thereafter, tinydns started.

    =======

    Unchecking "enable dns forwarders" does not turn dnsache off if it is on.  I suggest executing "svc -d /service/dnscache"

    =======

    pkg_mgr_installed.php knows I have dns-server and spamd installed, but status_services.php only shows spamd.

    =======

    tinydns_view_logs.php:

    The CLEAR LOG button doesn't work (but your comments show you know that).

    At the bottom of the page, the following is displayed:

    ?>

    I think there must be an unbalanced brace or something, but I couldn't find it.



  • 1.  Thanks, I'll fix this shortly
    2.  Tinydns status page is for LB/Failover (DNS)
    3.  TinyDNS will not start until you configure atleast one item on the settings page and click save
    4.  Not sure about DNS Forwarders, that was done by someone else.  Patches accepted.
    5.  See #4
    6.  I will look into it

    EDIT: looks like someone forgot to finish their code (not me):

    /* NEED TO FIX there are 2 logs /etc/tinydns/log/main/current and /etc/dnscache/log/main/current */

    $tinydnslogs = cat /etc/tinydns/log/main/current | /usr/local/bin/tai64nlocal | php -f /usr/local/pkg/tinydns_parse_logs.php | grep -v ":0";

    /* NEED TO FIX */
    if ($_POST['clear']) {
    // exec("rm /etc/tinydns/log/main/current");
    // exec("touch /etc/tinydns/log/main/current");
    }


Log in to reply