Squid still on system after removal



  • Hi Guys,

    Recently started using Pfsense and luving it so far. I installed Squid and LightSquid and then had some problem with the config. I decided to remove the two packages but the GUI had some errors and took a few trys before the package was removed. But after removal i could still see squid running on the system so i stopped it but the squid binary+config+logs are still on the system.

    Is this a bug ? I am using 2.0.1-Release. How can get rid of the squid so that i can install it fresh.
    Thanks



  • What browser are you using?

    Did you tried firefox or chrome?



  • I used firefox but can't remember if it was firefox or IE when i tried to uninstall the package. Can you tell me how to remove the squid from command line ? What binaries+config+logs and anyother entries in the system ?

    Thanks



  • I think the easiest way is(using firefox) install the package again and remove.



  • @marcelloc:

    I think the easiest way it(using firefox) install the package again and remove.

    Try this first and if it does not work go to command line and type:

    pkg_info
    

    You will find squid-2.xyz installed
    delete it and it dependencies with:

    pkg_delete -r squid-2.xyz
    

    But the correct way is to install and uninstall it using the GUI.


Log in to reply