[Resolvido]Squid + SquidGuard não fazer cache site



  • Bom dia pessoal, gostaria de uma grande ajuda do pessoal mais experiente que eu..

    Estou com um grande problema o qual não consigo fazer que determinado site seja acessado sem fazer cache.

    Ja inclui o dominio: www.portalredevw.com.br no Do not cache, da aba: Proxy Sever/Cache Management, mas não resolveu o problema.

    Também já tentei incluir a linha:

    acl NOCACHEDOMAIN dstdomain www.portalredevw.com.br
    no_cache deny NOCACHEDOMAIN

    no squid.conf mas também não obtive sucesso.

    O problema ocorre no momento em que preciso fazer o download de alguns arquivos de NF-e em PDF, os quais quando clico para fazer o download retornam uma página com o seguinte erro:

    ERROR
    The requested URL could not be retrieved

    –------------------------------------------------------------------------------

    While trying to process the request:

    GET /WebNFEletronica/SalvarPDF.aspx?IdNFe=11227214 HTTP/1.1
    Accept: /
    Referer: http://www.portalredevw.com.br/WebNFEletronica/ListaNFeDn.aspx
    Accept-Language: pt-br
    UA-CPU: x86
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Proxy-Connection: Keep-Alive
    Host: www.portalredevw.com.br
    Cookie: ASP.NET_SessionId=5vewrhiju2m3w0q5xk3ccb55; .AuthPortalRedeVW=B45B6560DBFD8E1C838BD8B0D6EFC3FC2E83494F981CEAA17241EFE964D62486B3FE1890973C96A36EA6AAA54E9553690EF0E68FBFC65A487AA9139877014A5192685FB3ED0D8A91CC86F0A51B3A96845E974AA9EF8B70433462D79518971403E2A0A6149320255FF1642FDF3740C73FF126592FDB91AC3DCCC654FD51372A23C1295ED46615E1A3; __utma=60873645.932152328.1333372464.1333372464.1333372464.1; __utmb=60873645.3.10.1333372464; __utmc=60873645; __utmz=60873645.1333372464.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)

    The following error was encountered:

    Invalid Response
    The HTTP Response message received from the contacted server could not be understood or was otherwise malformed. Please contact the site operator. Your cache administrator may be able to provide you with more details about the exact nature of the problem if needed.

    Alguém sabe como posso contornar este problema?

    Informações complementares:

    PFsense 2.0.1-RELEASE (i386)
    Instalado pacotes: Squid, SquidGuard e Lightsquid.
    Não uso proxy Transparente



  • Se você não usa proxy transparent, a forma mais simples de resolver esta pendenga é criar uma regra em "Firewall->Rules->Lan", dizendo que todas as conexões com destino ao respectivo site (TCP/80) estão liberadas - coloque isso acima da regra que você libera acesso do próprio Squid.

    Uma outra boa dica também é criar uma GPO (caso tenha um AD na rede) pra dizer as estações pra não usarem proxy para aquele destino ou ainda cadastrar manualmente na estação a exceção: http://forum.pfsense.org/index.php?action=dlattach;topic=44399.0;attach=19666;image

    Abraços!
    Jack



  • A tempos atras resolvi esse tipo de problema utilizando a opcão

    ignore_expect_100 on

    Tente colocar ela manualmente e veja se lhe ajuda.

    Maiores detalhes em

    http://www.squid-cache.org/Doc/config/ignore_expect_100/



  • @ccesario:

    Tente colocar ela manualmente e veja se lhe ajuda.

    Lembrando que, embora seja totalmente possível, é altamente desaconselhável efetuar inserções manuais diretamente nos arquivos de configuração. Se for inserir algo personalizado, procure usar o campo "custom" do Proxy Server! ;)

    Abraços!
    Jack



  • @JackL:

    Se você não usa proxy transparent, a forma mais simples de resolver esta pendenga é criar uma regra em "Firewall->Rules->Lan", dizendo que todas as conexões com destino ao respectivo site (TCP/80) estão liberadas - coloque isso acima da regra que você libera acesso do próprio Squid.

    Uma outra boa dica também é criar uma GPO (caso tenha um AD na rede) pra dizer as estações pra não usarem proxy para aquele destino ou ainda cadastrar manualmente na estação a exceção: http://forum.pfsense.org/index.php?action=dlattach;topic=44399.0;attach=19666;image

    Abraços!
    Jack

    Boa tarde meu amigo.

    fiz conforme descreveu mas ainda assim, quando tento fazer o download do arquivo pdf, vou para a página de erro acima.
    estou anexando um screen com minha tela do Rules/Lan.




  • Extra Seu Problema: Na rule "Regra PortalRede", deixe o campo "Port Source" como "Any" e o campo "Port Destination" como TCP/80.

    Em relação ao seu problema, qual é a máquina que você está testando (qual estação)?

    Você cadastrou o site nas exceções do browser da máquina também?

    Abraços!
    Jack



  • Sim, meu amigo Jack, estação de trabalho (172.168.13.21), esta com o site nas exceções como screen em anexo, e foi erro meu acertei o Rules/Lan.

    Mas ainda não obtive sucesso =/

    Lembrando que o site ainda continua no Porxy Server/Cache Mgmt/Do not Cache:

    www.portalredevw.com.br
    portalderevw.com.br
    187.86.212.32 (este é o ip do site)

    o que pode ser?






  • ch1c4um,

    Como você esta marcando o proxy nas estações de trabalho? Na mão ou usando WPAD/PAC?



  • @marcelloc:

    ch1c4um,

    Como você esta marcando o proxy nas estações de trabalho? Na mão ou usando WPAD/PAC?

    Na mão mesmo, adiciono o proxy e depois marco o checkbox: Não usar proxy para endereços locais, e insiro o site no campo: Não usar proxy para endereços iniciados com: www.portalredevw.com.br



  • Experimente colocar (separados por ponto-e-vírgula) outras exceções no browser (além do www.portalredevw.com.br):

    *.portalredevw;187.86.212.32

    Verifique os logs do Squid pra saber se as conexões estão realmente passando por dentro dele!

    Abraços!
    Jack



  • Ao Jack e todo pessoal que ajudou, muito obrigado deu certo!

    Criei um Alias com Type: Hosts e inseri o site que não desejava não passar pelo Proxy assim também não fazer cache, em Rules, criei uma regra acima de todas e principalmente da regra do Proxy e funcionou que é uma beleza. Observação não precisei nem colocar o host nas exceções do browser.

    Um abração galera e fica a dica para quem precisar.



  • @ch1c4um:

    Ao Jack e todo pessoal que ajudou, muito obrigado deu certo!

    Não tem por onde… :D

    … funcionou que é uma beleza

    Que bom! ;)

    Observação não precisei nem colocar o host nas exceções do browser.

    Exatamente… No seu caso específico, ou você libera via regra de firewall ou cria a exceção no browser (manualmente ou de forma automatizada)!

    Abraços!
    Jack


Log in to reply