Shrew client could not browse by hostname



  • hi all, i have been using shrew soft VPN client and Pfsense 2.0.1. configured shrew soft for IPSEC VPN. everything else working fine apart from i could not browse the network servers by hostname, can't ping either. only way i can browse network shares is by entering IPaddress. setup the pfsense to provide DNS to clients which is DNS server on LAN and given the secondary dns as Pfsense box's with no luck. any help would be appreciated. thanks



  • In 2.0.1, this should work if you leave shrew on the defaults (enable dns, auto) and set the DNS servers under IPSec, Mobile, Client Configuration. Make sure you have rules allowing the traffic.



  • hi Dot, i have done the first two. what do you mean by rules. i have created a rule in which allows any to any as shown in the attachment. should i create more rules? thing is, i can access the network shares by ip address tho. thanks

    ![ipsec rule.png](/public/imported_attachments/1/ipsec rule.png)
    ![ipsec rule.png_thumb](/public/imported_attachments/1/ipsec rule.png_thumb)



  • That should work. Verify you are providing the correct dns domain name and try to ping the full dns name- e.g. server.company.local.


Log in to reply