How Does Link Aggregation



  • Now I am using PF2.1 lastest version.

    I have do PPPoE multilink and I try use lacp in LAGG configuration. But its all can not success for Link Aggregation.

    when I setup PPPoE multilink and lacp, all link down.

    when I only setup  PPPoE multilink WAN is online. but it is seems has no Link Aggregation.

    Who has the experience of success?




  • Last 50 PPP log entries
    Jan 12 19:06:06 ppp: [wan_link1] PROTOCOMP
    Jan 12 19:06:06 ppp: [wan_link1] MRU 1492
    Jan 12 19:06:06 ppp: [wan_link1] MAGICNUM 1804757c
    Jan 12 19:06:06 ppp: [wan_link1] MP MRRU 2048
    Jan 12 19:06:06 ppp: [wan_link1] MP SHORTSEQ
    Jan 12 19:06:06 ppp: [wan_link1] ENDPOINTDISC [802.1] ** e0 4c 1e* f4            (LAN MAC)
    Jan 12 19:06:06 ppp: [wan_link1] LCP: rec'd Configure Request #21 (Req-Sent)
    Jan 12 19:06:06 ppp: [wan_link1] MRU 1492
    Jan 12 19:06:06 ppp: [wan_link1] AUTHPROTO PAP
    Jan 12 19:06:06 ppp: [wan_link1] MAGICNUM 0fc708b3
    Jan 12 19:06:06 ppp: [wan_link1] LCP: SendConfigAck #21
    Jan 12 19:06:06 ppp: [wan_link1] MRU 1492
    Jan 12 19:06:06 ppp: [wan_link1] AUTHPROTO PAP
    Jan 12 19:06:06 ppp: [wan_link1] MAGICNUM 0fc708b3
    Jan 12 19:06:06 ppp: [wan_link1] LCP: state change Req-Sent –> Ack-Sent
    Jan 12 19:06:06 ppp: [wan_link1] LCP: rec'd Configure Reject #113 (Ack-Sent)
    Jan 12 19:06:06 ppp: [wan_link1] PROTOCOMP
    Jan 12 19:06:06 ppp: [wan_link1] MP MRRU 2048
    Jan 12 19:06:06 ppp: [wan_link1] MP SHORTSEQ
    Jan 12 19:06:06 ppp: [wan_link1] ENDPOINTDISC [802.1] ** e0 4c 1e* f4            (LAN MAC)
    Jan 12 19:06:06 ppp: [wan_link1] LCP: SendConfigReq #114
    Jan 12 19:06:06 ppp: [wan_link1] MRU 1492
    Jan 12 19:06:06 ppp: [wan_link1] MAGICNUM 1804757c
    Jan 12 19:06:06 ppp: [wan_link1] LCP: rec'd Configure Ack #114 (Ack-Sent)
    Jan 12 19:06:06 ppp: [wan_link1] MRU 1492
    Jan 12 19:06:06 ppp: [wan_link1] MAGICNUM 1804757c
    Jan 12 19:06:06 ppp: [wan_link1] LCP: state change Ack-Sent –> Opened
    Jan 12 19:06:06 ppp: [wan_link1] LCP: auth: peer wants PAP, I want nothing
    Jan 12 19:06:06 ppp: [wan_link1] PAP: using authname "227337"
    Jan 12 19:06:06 ppp: [wan_link1] PAP: sending REQUEST #1 len: 24
    Jan 12 19:06:06 ppp: [wan_link1] LCP: LayerUp
    Jan 12 19:06:07 ppp: [wan_link1] PAP: rec'd ACK #1 len: 5
    Jan 12 19:06:07 ppp: [wan_link1] LCP: authorization successful
    Jan 12 19:06:07 ppp: [wan_link1] Link: Matched action 'bundle "wan" ""'
    Jan 12 19:06:07 ppp: [wan_link1] Can't join bundle wan without multilink negotiated.
    Jan 12 19:06:07 ppp: [wan_link1] link did not validate in bundle
    Jan 12 19:06:07 ppp: [wan_link1] LCP: parameter negotiation failed
    Jan 12 19:06:07 ppp: [wan_link1] LCP: state change Opened –> Stopping
    Jan 12 19:06:07 ppp: [wan_link1] LCP: SendTerminateReq #115
    Jan 12 19:06:07 ppp: [wan_link1] LCP: LayerDown
    Jan 12 19:06:07 ppp: [wan_link1] rec'd proto IPCP during terminate phase
    Jan 12 19:06:08 ppp: [wan_link1] LCP: rec'd Terminate Ack #115 (Stopping)
    Jan 12 19:06:08 ppp: [wan_link1] LCP: state change Stopping –> Stopped
    Jan 12 19:06:08 ppp: [wan_link1] LCP: LayerFinish
    Jan 12 19:06:08 ppp: [wan_link1] PPPoE: connection closed
    Jan 12 19:06:08 ppp: [wan_link1] Link: DOWN event
    Jan 12 19:06:08 ppp: [wan_link1] LCP: Down event
    Jan 12 19:06:08 ppp: [wan_link1] LCP: state change Stopped –> Starting
    Jan 12 19:06:08 ppp: [wan_link1] LCP: LayerStart
    Jan 12 19:06:08 ppp: [wan_link1] Link: reconnection attempt 199 in 1 seconds



  • Look at these pictures.








  • @chpalmer:

    Look at these pictures.

    yes, I have do it. but network Speed ​​does not increase.




  • Nope- you have not set yours up the same as the pictures.  Until you delete all the PPPOE interfaces and set them up like the pictures Ive provided it will not work.

    MLPPP is set up on the pppoe page.

    Is this box your only access to the internet?



  • @chpalmer:

    Nope- you have not set yours up the same as the pictures.  Until you delete all the PPPOE interfaces and set them up like the pictures Ive provided it will not work.

    MLPPP is set up on the pppoe page.

    Is this box your only access to the internet?

    I have try it, but it still can't normal work.

    Last 50 PPP log entries
    Jan 13 21:42:30 ppp: [wan_link1] PROTOCOMP
    Jan 13 21:42:30 ppp: [wan_link1] MRU 1492
    Jan 13 21:42:30 ppp: [wan_link1] MAGICNUM 32782f63
    Jan 13 21:42:30 ppp: [wan_link1] MP MRRU 2048
    Jan 13 21:42:30 ppp: [wan_link1] MP SHORTSEQ
    Jan 13 21:42:30 ppp: [wan_link1] ENDPOINTDISC [802.1] 1e b3 f4
    Jan 13 21:42:31 ppp: [wan_link1] LCP: rec'd Configure Request #150 (Req-Sent)
    Jan 13 21:42:31 ppp: [wan_link1] MRU 1492
    Jan 13 21:42:31 ppp: [wan_link1] AUTHPROTO PAP
    Jan 13 21:42:31 ppp: [wan_link1] MAGICNUM 1b6b19cc
    Jan 13 21:42:31 ppp: [wan_link1] LCP: SendConfigAck #150
    Jan 13 21:42:31 ppp: [wan_link1] MRU 1492
    Jan 13 21:42:31 ppp: [wan_link1] AUTHPROTO PAP
    Jan 13 21:42:31 ppp: [wan_link1] MAGICNUM 1b6b19cc
    Jan 13 21:42:31 ppp: [wan_link1] LCP: state change Req-Sent –> Ack-Sent
    Jan 13 21:42:31 ppp: [wan_link1] LCP: rec'd Configure Reject #27 (Ack-Sent)
    Jan 13 21:42:31 ppp: [wan_link1] PROTOCOMP
    Jan 13 21:42:31 ppp: [wan_link1] MP MRRU 2048
    Jan 13 21:42:31 ppp: [wan_link1] MP SHORTSEQ
    Jan 13 21:42:31 ppp: [wan_link1] ENDPOINTDISC [802.1]  1e b3 f4
    Jan 13 21:42:31 ppp: [wan_link1] LCP: SendConfigReq #28
    Jan 13 21:42:31 ppp: [wan_link1] MRU 1492
    Jan 13 21:42:31 ppp: [wan_link1] MAGICNUM 32782f63
    Jan 13 21:42:31 ppp: [wan_link1] LCP: rec'd Configure Ack #28 (Ack-Sent)
    Jan 13 21:42:31 ppp: [wan_link1] MRU 1492
    Jan 13 21:42:31 ppp: [wan_link1] MAGICNUM 32782f63
    Jan 13 21:42:31 ppp: [wan_link1] LCP: state change Ack-Sent –> Opened
    Jan 13 21:42:31 ppp: [wan_link1] LCP: auth: peer wants PAP, I want nothing
    Jan 13 21:42:31 ppp: [wan_link1] PAP: using authname "227337"
    Jan 13 21:42:31 ppp: [wan_link1] PAP: sending REQUEST #1 len: 24
    Jan 13 21:42:31 ppp: [wan_link1] LCP: LayerUp
    Jan 13 21:42:31 ppp: [wan_link1] PAP: rec'd ACK #1 len: 5
    Jan 13 21:42:31 ppp: [wan_link1] LCP: authorization successful
    Jan 13 21:42:31 ppp: [wan_link1] Link: Matched action 'bundle "wan" ""'
    Jan 13 21:42:31 ppp: [wan_link1] Can't join bundle wan without multilink negotiated.
    Jan 13 21:42:31 ppp: [wan_link1] link did not validate in bundle
    Jan 13 21:42:31 ppp: [wan_link1] LCP: parameter negotiation failed
    Jan 13 21:42:31 ppp: [wan_link1] LCP: state change Opened –> Stopping
    Jan 13 21:42:31 ppp: [wan_link1] LCP: SendTerminateReq #29
    Jan 13 21:42:31 ppp: [wan_link1] LCP: LayerDown
    Jan 13 21:42:31 ppp: [wan_link1] rec'd proto IPCP during terminate phase
    Jan 13 21:42:31 ppp: [wan_link1] LCP: rec'd Terminate Ack #29 (Stopping)
    Jan 13 21:42:31 ppp: [wan_link1] LCP: state change Stopping –> Stopped
    Jan 13 21:42:31 ppp: [wan_link1] LCP: LayerFinish
    Jan 13 21:42:31 ppp: [wan_link1] PPPoE: connection closed
    Jan 13 21:42:31 ppp: [wan_link1] Link: DOWN event
    Jan 13 21:42:31 ppp: [wan_link1] LCP: Down event
    Jan 13 21:42:31 ppp: [wan_link1] LCP: state change Stopped –> Starting
    Jan 13 21:42:31 ppp: [wan_link1] LCP: LayerStart
    Jan 13 21:42:31 ppp: [wan_link1] Link: reconnection attempt 9 in 2 seconds






  • Your setup looks right now and your logs show your box attempting to negotiate the links…

    Does your ISP know that you want MLPPP?  You have to get them to set it up on their end.



  • I dont know ISP about this.  :-X

    In our ISP is a monopoly industry.There is no room for negotiation.



  • For you to get MLPPP, they have to give you MLPPP. If they don't set it up correctly on their end, then it won't work on your end.


Log in to reply