500 - Internal Server Error



  • Hi,

    /var/log/lighttpd.error.log contains a lot of errors :
    2012-04-05 15:00:20: (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2012-04-05 15:00:20: (mod_fastcgi.c.3025) backend died; we’ll disable it for 1 seconds and send the request to another backend ins
    tead: reconnects: 0 load: 1

    Of course, it produce a lot of problems : bad sync beetween nodes, interface hanging, etc.

    How can I debug this ? Do you reproduce the problem ?

    It is the snapshot of Wed Apr 4 19:15:35 EDT 2012.
    Thanks !


  • Rebel Alliance Developer Netgate

    If you upgrade to a more recent snapshot, does this still happen? (You can use the console upgrade by URL function to load an updated snapshot)



  • I had this happen after a gitsync.
    Manually restarted the webui with 11.



  • Yes the problem persists on Mon Apr 16 04:08:01 EDT 2012 version.


  • Rebel Alliance Developer Netgate

    We’ll need more info about what you have configured there, or what you have happening with the GUI, since I can’t reproduce this on any of my 2.1 systems, they all work fine.



  • I just install the last version on two Virtualbox VM. I define IPv4 and IPv6 address on one interface (WAN) for each. I define a CARP address on this WAN. I define a DNS server. I open the firewall, so for each VM can see the other, can ping google, update on PFSense.

    Each time I click on a page the log is growing up.

    What information can I give you ? Are you interested by the VirtualDisk of these machines ?



  • I try a lot of things :

    • Removing all IPv6 addresses and CARP
    • Increasing the Max Processes in Webconfigurator
    • Disabling IPv6 in Advanced menu
    • Try to add the name in /etc/hosts
    • Rebooting
    • Try to update to the updated version
    • Removing HA (pfsync and conf)
      And no luck.

    Just if it can help, the IPv4 for the PFsense is not resolvable.
    When I increase the Max Processes to 4, the message change to  unix:/tmp/php-fastcgi.socket-3 instead of  unix:/tmp/php-fastcgi.socket-1

    Just to be sure, I install a 2.0.1 on a new VM (no error detected), upgrade it to 2.1, and then the problem occurs.
    I install a fresh 2.1 (on another VM) and the problem occurs too…

    I saw an error message concerning a low memory (I use 128MB RAM VM, which is the default for VirtualBox). It disable APC. I try to put 1GB to VM and YEAH !! It works !!! (put 256MB works too and it is really quicker than  without APC !!!)


  • Rebel Alliance Developer Netgate

    OK, so if it’s low memory, there are already a couple of tickets on http://redmine.pfsense.org/ that cover that type of issue. If you have that low memory you do not want to increase the number of GUI processes, it can only handle one.



  • Yes ! I put more memory and the problem is solved (for me). I think some guys will have the problem on embedded devices.

    Thanks for your time !


  • Rebel Alliance Developer Netgate

    Most embedded devices that are still in use have at least 256MB RAM, like most of the popular ALIX models. (There are a couple with 128MB but they are much less common)


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy