Clock on jan 1 2000, ntp not working



  • I am trying to switch on my Alix-boards from m0n0wall to pfSense. Everything is working great with pfSense on my Alix-boards, except for the time, after reboot it stays on Jan 1 2000.

    In "General Setup" I entered time.euro.apple.com for NTP time server.

    Under "Status" / "Services" I can see that the ntpd is running.

    I have internet-access, I can ping and resolve servers on the internet under "Diagnostics" / "Ping"

    What am I doing wrong? With m0n0wall on the boards I have no issues with setting the clock….



  • After re-installing pfsense, ntp-client is working again. My LAN en WAN are on the same local network during my test-setup, so I disabled the two blocking-options under Private Networks. That's probably what fixed it.



  • Nope, I was wrong, after rebooting the Alix again the clock is at jan 1st 2000 again and won't do a ntp-sync… I'm at a loss...


  • Netgate Administrator

    You can't have WAN and LAN on the same subnet. That will break routing.

    Steve



  • if you still have them on the same subnet, that's probably why, that will cause issues.



  • You guys are right, after putting WAN en LAN in different subnets, clock is syncing again without problems, also after reboots. The funny thing is that with m0n0wall I had no troubles with WAN and LAN on the same subnet, ntp-sync was always working. Anyway: problem solved.



  • m0n0wall will have issues with both NICs on the same subnet as well, but such issues with both are intermittent generally, you're lucky if that didn't break with m0n0wall. It's not a valid or useful config anyway with any router or firewall.


Log in to reply