Https webconfigurator 443 works https does not



  • Hello All,

    (2) pfSense-2.0.1-RELEASE
    mulit-wan single-lan
    squid
    squidGuard
    Lightsquid

    Installed two new pfSense-2.0.1-RELEASE servers, identical hardware at two sites.

    Webbrowsing works fine, so I move on to setting up load balancing and failover for gateways.
    After reading the several tutorials on various methods of accomplishing this on 2.0.1 enabled https as is required.
    After hitting the apply button I could never get into the webgui using https://###ipaddress
    I could however access the webgui using  ###ipaddress:443
    This is the same behaviour using two versions of IE and two versions of Firefox.

    Also it appears now that sites are still being blocked but the client never recieves the traditional 403 forbidden message. the webpage simply times out,,and is logged in the squidGuard 'blocked' log.
    I do not see any references in either NAT or lan for port 443 other than at the top of lan firewall rules for ports 22,80,443 anti-lockout.
    We have used pfSense-1.2.3-RELEASE for the last two years so I am fairly familiar with the webgui configs of each piece of pfSense.

    One oddity I have noticed,even though the versions of squid,squidGuard, and Lighsquid, are identical on both pfSense machines,on the machine in question there is an additional checkmark for "Clean advertsiing" under squidGuard>General Settings,,,were I do not see this on the correctly working box?

    EDIT: Just for completeness ,after switching the webconfiguator back to http( from https) the client's do receive the 403 forbidden message on all used versions of IE and firefox. Nothing else is changed in regards to squid or squidGuard.

    Thank You,
    Barry


Log in to reply