Installer could not find any disks suitable for installation …

  • Hi All,

    I am installing pfSense-2.0.1-RELEASE-amd64 as a KVM guest with Debian GNU/Linux 'Sid' as host.  Installation boot-up is ok but when opting to install to disks, have encountered error of Installer could not find any disks suitable for installation.

    Dmesg logs in the pfsense guests shows
    "ad0: FAILURE - READ_DMA status=41 <ready,error>error=4 <aborted>LBA=

    Screenshots as attached.

    Tested booting FreeBSD 8 & 9 (x86_64) bare metal on the same Debian hosts in which the above error msg does not appear.
    Tested booting FreeBSD 8 & 9 (x86_64) as KVM guests on the same Debian host:  above error msg does not appear.
    Testing successfully installing FreeBSD 8 (x86_64) as KVM guest on the same Debian host: above error msg does not appear.

    Hor Jiun Shyong


  • FreeBSD 8.what? 2.0.1 is 8.1, you were probably trying 8.3. If it is an 8.1 issue (shouldn't be, KVM works for many others, but maybe that's a newer version or diff circumstance), then 2.1 snapshots on 8.3 should work. Check the 2.1 board here.

  • FreeBSD 8.0 and 9.0.

    The first problem install is on the Debian host with LVM.  (lvm2 version: 2.02.88-2)

    I did another test install of pfsense 2.0.1 as KVM guest on another different Debian Sid host which is not using LVM and there is no  "ad0 error message"  and the installation is successful.  I think the problem could be LVM related.

  • I have live migrated the good pfsense installation (from the second Debian host without LVM) to the first Debian host with LVM (which was having installation problem).  After a reboot of the pfsense guest, there was some some disk error which leads to kernel panic. This was solved after I ran fsck.  Now the guest pfsense is running ok.

    Attached is the pfsense crash report after the live migration.


Log in to reply