HELP! Back to previous version.



  • I just downloaded the April 8 Snapshot and everything has gone to #@!!.  I backed up from the Firmware page first, but the system will not restore from there.  I then reinstalled from scratch, but when I gitsync I'm evidently getting a newer version than I was using before the update.  It is throwing this error:

    Fatal error: Call to undefined function pfSense_interface_listget() in /etc/inc/interfaces.inc on line 67

    How do I get back to a stable version of 2.1?  This is urgent because I need to keep the SixXS tunnels up.  Thanks.



  • The newer code needs a newer pfSense.so PHP module. So if you have gitsync enabled you'll check out the newer code, but without the binaries.

    You didn't tell what was wrong with the snapshot either, there is a new one going up as we speak that should fix a filter rule.



  • Snapshots has images going back to the 22nd of March. I've been running the April 3 snapshot with no major issues. Turn off gitsync?

    I had a problem with last night's snapshot as well. The two things I noticed before rolling back to the 4/3 snapshot:

    • My WAN gateway was now called WAN_DHCP in the Gateways box on the dashboard.

    • DNS didn't work.

    I'll try reproducing this when I can cause an outage, but rolling back was the right move in my pre-coffee haze this morning. (I'd hit the upgrade button and fallen asleep last night)

    I was able to restore from the "full backup" on the Firmware Update page, but there's no UI there. I hit restore, it said it was restoring, but there was no indication of progress or completion. Eventually I shelled in, and since I didn't see anything in the process table that looked like a restore in progress, rebooted.

    It came up just fine with the 4/3 snapshot.



  • Sorry.  I rebooted the pfSense and when it rebooted, it threw the same error, but this time I had no internet access.  So I just went through the whole install again.  Thank God version 2.0.1 accepts a 2.1 config file or I'd still be trying to get back to where I was.

    I tried to send you the crash dump when I rebooted after installing the 4/8 snapshot, but (having crashed) I had no internet access.  I did cut and paste it to Notebook++, though, so I can send it to you (it's too big to paste here, I think).  The snapshot only crashed one machine, but it did have a filter error on both.  It was a line like

    pass out route-to (  2001:470:7🔢:1 ) inet6 from 2001:470:7🔢:2/64 to !2001:470:7🔢:2/64 keep state allow-opts label "let out anything from firewall host itself"

    that was causing the problem.  Having said that, I am now only IPv4 connected on one machine.  I can easily get the other to this point.  What do I need to do to get a stable 2.1 up and running again?



  • I tried restoring just as you did, but seeing no progress, potentially interrupted the process.  At any rate, I couldn't get back and I've since reinstalled 2.0.1.  I'm just not sure where to go now.  The second machine may restore now that I know to leave it alone for a while.  How long did you wait?



  • a fix for the filter rule error just went in, I think the snaps have been restarted with that fix in.

    You could always just have loaded a april 4th snap and it would just work. I always have old snapshots in my download dir though, but if you keep tracking just the autoupdate in the UI, you would have had none.

    But you could download a older one directly from http://snapshots.pfsense.org/ and then upload that to the UI.



  • OK!  You ain't seen panic till you've seen me panic!  Thanks, guys.  I'm at the 4/4 snapshot now and it looks stable.  I downloaded it and used the Manual Update tab to install it.  So you think it's safe to install the latest version this way too?



  • yep, it's no different from the autoupdate, just more manual steps.

    But that way you have a backup version you can always restore. We are currently going through a few builder change this week though.



  • @databeestje:

    But that way you have a backup version you can always restore.

    So, that UI is… challenging?

    I click "restore" it says it's restoring, and that's it. No further feedback.

    How is this supposed to work?


Log in to reply