Pfsense 2.0.1 + avaya sip trunk = not working



  • I have an Avaya PBX behind my firewall. On that Avaya there is a SIP trunk to a provider for a DID in another city (to cut costs on long distance charges) anyway.

    The SIP trunk isn't working. The vendor for the Avaya is telling me the firewall is blocking it.
    I have firewall set to conservative optimization.
    Set up the outbound nat (set to manual)
    forwarded incoming UDP/TCP 5060-5080 to go to the Avaya
    also forwarded incoming to 5060-5080 to Avaya

    still doesn't work. any ideas what else I could be missing?



  • "doesn't work" is very vague, you need to provide more detailed info.

    Did your setup work before with another firewall ?
    Do you see any SIP traffic being blocked by pfsense ? (check Status -> System Logs -> Firewall)
    Do you have "one way sound" ?
    etc



  • Sorry yeah, I had to try to pry to get Avaya login info from vendor.

    Problem thats happening is it's only doing one way traffic (I believe calling out works, just when people try to dial the number, it just gets busy signal)
    The status screen shows the SIP trunk is okay I believe.

    Yes it did. I put in pfsense to replace a cheap dlink.

    I see SIP traffic that MIGHT be getting blocked but it looks like some kind of session problem for example.
    in the block log i see;

    source ip as the provider, source port is random but between 17180-17189ish to my WANIP:1461, 7355, 13249, 19143, 7355, 13249, 19143 all UDP.

    Let me test outgoing to confirm it works.



  • Outgoing calls were not working and the trunk wasnt up.

    I tried using siproxd and it didn't work either.

    The only way I fixed it was doing a massive port forward
    I got the IP of the SIP provider, forwed their entire network so 66.66.66.0/24 as source, all ports source, dest my wan, dest port 1-65355 going to my phone system
    fixed it.



  • Just to update this.

    Turned out to be an unstable STUN server that we were using. We just used a different from from VOIP info. The 3cx one is very unstable.

    As well as just doing a rule from the three IPs from our sip provider helped a lot too.


Log in to reply