OpenNTP client taking forever?



  • My newly-configured pfSense box seems to have a problem during startup… it hangs at "Starting OpenNTP client..." for literally 2-3 minutes.  I have network connectivity, so I don't think that's the issue (unless the interface isn't coming up until after the NTP client for some reason?).  Why might it be taking so long, and what can I do to fix it?

    I tried searching the forums, but the closest I found was someone having a similar issue (but only with a 20-30 second delay), and his issue was apparently due to not having internet access when booting, as connecting the box to the internet resolved it for him, which isn't working for me.



  • Unfortunately ntp logging has been broken for a long time. If it was fixed it might provide a clue or two. Have you looked in the system log for ntp entries? (Take a look in the output from pfSense shell command```

    clog /var/log/system.log


  • Netgate Administrator

    I have always seen some delay at that point, no where near 2-3 minutes though.
    How often do you boot your box?  ;)

    Steve



  • Since it's not in production yet, I just boot it when I'm tinkering with it, then shut it back down.  However, this error seems to have gone away since I fixed my fstab entries the other night (pfSense was originally booting off /dev/d1s1a because it was installed from USB stick, but after removing the stick, it moved to /dev/d0s1a because of the way my BIOS handles USB devices as hard drives).  Not sure if that was the underlying cause, or just coincidental.  Now OpenNTP goes through its thing in like 5-10 seconds.

    Also, at one point I had the box running with a USB NIC too, but switched over to the onboard and had left the configuration the same between the two.  I finally unplugged the USB NIC the night I did the fstab thing, until I'm ready to use it again… so I'm wondering if maybe OpenNTP was trying to route over the (not-connected) USB NIC.

    Anyways, it seems to be behaving for the time being :P


Log in to reply