Squid start and stop imedialtely



  • i have squid and squid guard installed but when i check service status i found it started and when i refresh i have it stop and again and again stop and again start

    this is system log

    Apr 15 20:06:54 squid[21713]: Squid Parent: child process 50831 started
    Apr 15 20:06:54 squid[50831]: mimeLoadIcon: cannot parse internal URL
    Apr 15 20:06:54 kernel: pid 50831 (squid), uid 62: exited on signal 6
    Apr 15 20:06:54 squid[21713]: Squid Parent: child process 50831 exited due to signal 6
    Apr 15 20:06:57 squid[21713]: Squid Parent: child process 10394 started
    Apr 15 20:06:58 squid[10394]: mimeLoadIcon: cannot parse internal URL
    Apr 15 20:06:58 squid[21713]: Squid Parent: child process 10394 exited due to signal 6
    Apr 15 20:06:58 kernel: pid 10394 (squid), uid 62: exited on signal 6
    Apr 15 20:06:58 squid[21713]: Exiting due to repeated, frequent failures
    Apr 15 20:06:58 php: : SQUID is installed but not started. Not installing "nat" rules.
    Apr 15 20:06:58 php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Apr 15 20:06:58 php: : SQUID is installed but not started. Not installing "filter" rules.



  • which version of squid do you use ?
    Is squid running without squidguard - or squidguard disabled ?



  • @mohandshamada:

    Apr 15 20:06:54 squid[21713]: Squid Parent: child process 50831 started
    Apr 15 20:06:54 squid[50831]: mimeLoadIcon: cannot parse internal URL
    Apr 15 20:06:54 kernel: pid 50831 (squid), uid 62: exited on signal 6
    Apr 15 20:06:58 squid[21713]: Exiting due to repeated, frequent failures

    You have config problems, check if you have enabled custom settings and/or try a package reinstall.



  • i solve it but i need now to flush cache content and removw all cache and i want to know if cach is working and chaching or not
    cause i have another prob.
    i remove pfsense and reinstalled it many times and install squid and light squid and in every time i found that lightsquid report is reporting that i use cache and specify the content that cached before the removing pfsense
    how does this work despite i was erase all hard disk content and reinstall pfsense from zero


Log in to reply