SquidGuard Time Type Problem on GUI



  • I was just re-installing a clean test 2.1-DEV nanobsd system with the Apr 16 16:52:53 EDT 2012 image.
    I installed Squid 2.7.9 and then SquidGuard 1.4_2, both from the GUI Package Manager interface. I go to Services, Proxy Filter, Times, click "+" to add a new set of times. In the "Values" section I enter the first "Weekly" time type, "all" days with a time range. Then click "+" to start entering the next time range.
    The Time Type field on new rows only has the value "Date". "Weekly" is not available.
    So I can't enter multiple time ranges, or different time ranges for different days of the week.
    I don't know if this is also an issue when running on 2.0.1 and loading the latest SquidGuard package version.
    Maybe it is related to the current work being done on Squid3 and making SquidGuard work with that also?



  • Note: As yet, there aren't pbi's for Squid3, so I can't try using Squid3+SquidGuard on 2.1-DEV. I tried removing SquidGuard then Squid and installing Squid3 - the xml, php etc files get downloaded but no actual pbi with Squid3 in it. No rush for Squid3 pbi, just mentioning it here to document and clarify the current status.



  • 2.1-DEVELOPMENT (i386)
    built on Mon Apr 23 08:11:16 EDT 2012
    FreeBSD 8.3-RELEASE

    When I open or edit a "Times" entry on SquidGuard the first blank row has the full set of options available for "Time Type" and "Days" columns. But when I use the "+" button to add a row the "Time Type" dropdown only has "Date" and the "Days" dropdown only has "mon wed fri sun".

    The workaround is to save after adding each new time row, then edit again to get a new blank row displayed with the full set of dropdown options.

    I haven't noticed this on 2.0.1, so I presume it is some interaction with the GUI handling on 2.1? I don't have a 2.0.1 system easily available now to try 2.0.1 again.





Log in to reply