Squid with dual-WAN loadbalancing - anyone figured it out?



  • Hi!

    Has anyone figured out how to make this work?

    *pfSense 2.0.1
    *One LAN
    *Two WANs set up with load balancing (not fail-over)
    *Squid

    Have tried all the suggestions around, but doesn't look like anybody has made this work.



  • An alternative if this doesn't work would be to have squid working for traffic towards one WAN and traffik to the other WAN
    could go directly. However I couldn't make this work as squid doesn't pass traffic when the current default gateway WAN isn't used.

    Does someone know how to make squid work for one WAN and still let traffic through the other WAN?



  • there are a zillion posts about this … try searching the forums and ask questions at the respective posts



  • Yes, but no posts state that it works, none have reported it OK, so just wondering if anyone that might have made it work without
    posting about it could share their configs :-)



  • i did try this and it works fine . the squid work in transparent mode . and every thing work fine except one thing , i dont know if you will face it or not . see here
    http://forum.pfsense.org/index.php/topic,48199.0.html



  • We have a multi-WAN setup and Squid load-balancing works (inbound).  We use transparent mode for Squid, so by default it just uses the default gateway for inbound traffic (leaving the other two gateways unused).  So, we setup a floating firewall rule to "loop" the interface traffic to that default WAN gateway then thru to the gateway group.  Then, we added "tcp_outgoing_address 127.0.0.1" to Custom Options of Squid to complete the setup.

    Sample: we have OPT1, OPT2 (as default GW), OPT3 interfaces in a gateway group (GG1).

    Our firewall rule looks like this:

    Proto: TCP
    Source: OPT2 address
    Port: *
    Destination: *
    Port: 80 (HTTP)
    Gateway: GG1

    Don't forget to tick "Apply the action immediately on match" for the floating rule. ;)



Log in to reply