DevelopersBootStrapAndDevIso, pfSense 2.1



  • I feel like I'm either missing something obvious, or looking at the wrong document.

    Googling various keywords along the lines of "source code to pfSense" always comes up with
        http://devwiki.pfsense.org/DevelopersBootStrapAndDevIso
    pretty high in the list.

    The first option of just downloading a virtual machine is perfect.

    http://cvs.pfsense.org/~sullrich/pfSenseDevBuilder/pfSense.ova

    Unfortunately, it seems this virtual machine is out of date.

    When you boot up the machine, it runs /etc/rc.local which kicks off a bootstrap and build process which fails almost immediately.
    The first stumbling block is that the freebsd 8.1 ports area has been archived, so pkg_add -r couldn't find the requested packages.
    This is easy to work around, I chose to just ftp to ftp.freebsd.org, go to pub/FreeBSD/ports/i386/packages-8-stable/Latest
    grab fastest_cvsup.tbz and perl.tbz. and then run
      pkg_add perl.tbz
      pkg_add fastest_cvsup.tbz

    then edit /etc/rc.local and change RELENG_2_0 to RELENG_2_1 in both locations you get a match.  namely
      PFS_VERSION=RELENG_2_1
      …
      cd /home/pfsense/tools/pfPorts && ./buildports.RELENG_2_1

    At this point, reboot and see if the automated process now works.  Well yes and no, we get further but it doesn't
    look like they are happening as they are supposed to.

    For instance,
      >>> Finding patch rejects...

    WARNING!  Rejected patches found!  Please fix before building!

    /usr/pfSensesrc/src/ip_carp.c.rej
      /usr/pfSensesrc/src/pf.c.rej
      /usr/pfSensesrc/src/mbuf.h.rej

    I've only looked at the mbuf.h reject so far, but at the moment I can't see how it
    didn't match.  So whilst I can probably hack the patch so it does apply properly, it
    seems I'm somewhere I shouldn't be...  I think I can safely assume that this is
    obviously not how the automated build bootstraper is supposed to work.

    I've tried running set_version.sh or menu.sh, but ultimately with no success.

    Is RELENG_2_1 the correct release to get a build environment that somewhat matches the images on snapshot.pfsense.org?

    pfSense 2.0.1 runs fine on my soekris and almost suits my needs, except for the lack of v6.  Going to 2.1 snapshots I run into a shared problem with others running flash based root filesystems where there are frequent "hangs" and this makes it impossible to put into a "production" environment.

    So, I'd like to debug the problem, but can't recreate a starting point, let alone make changes to it.

    Any suggestions, ideally an updated ova or set of instructions would be appreciated.

    Thanks,

    • Mark


  • The problem here is pf_route-to-crash_fixes.diff. It probably needs to be updated since something changed in the kernel source.



  • Thanks to ermalluci … it looks like we are going to be able to build 2.1 now.



  • I think you need to match the FreeBSD version of the pfSense version you want to build.  Currently this is 8.3 for pfSense 2.1.



  • I am using 8.3 to build my 2.1 images. I have not tried to just FreeBSD version to build. Though I did try to build 2.1 on 9.0 (since it has some patches and at the time it was going that way) it was never successful.


  • Rebel Alliance Developer Netgate

    The patches were broken for a couple days but they should be fine again now.


Log in to reply