2.0.1 RELEASE php hangs - cannot kill -9



  • Hi All,
    Long time user of a very stable 1.3 box (live CD). Just popped in the 2.0.1 RELEASE cd. No problems booting. The GUI worked just fine for the first few minutes. Then was unreachable. Specifically, you can connect on port 80, but you get no response from the GET.

    I searched quite a bit for this and found that some recommended killing httpdlight and php and then restarting the web server. Tried that but realized that I have about 4 instances of php running that cannot be killed. I tried kill -9 many times.

    How do I get strace and/or lsof installed so I can track down what php is stuck doing?

    BTW, all networking and firewall rules seems to be working fine.

    EDIT: OK just realized BSD uses truss - duh. Running truss on the frozen php processes revealed nothing (no activity). I did however run truss on lighttpd. Noticed that it did:

    connect(6,{ AF_UNIX "/tmp/php-fastcgi.socket-1" },27) = 0 (0x0)

    Running sockstat revealed that the stuck php processes all had that socket open. I removed the sockets from /tmp and restart httpd. Now things seem to be working. But for how long…


  • Rebel Alliance Developer Netgate

    Usually this is from the rate program on the realtime traffic graph getting stuck…

    The usual way to kick it in the rear is (via ssh/console shell)

    killall -9 rate
    

    If that doens't work:

    killall -9 php; killall -9 lighttpd; /etc/rc.restart_webgui
    

Log in to reply