LoadBalance com Squid



  • Bom dia comuniade. Existe alguma solução funcional para o velho problema entre LoadBalance e o Squid?

    Tentei configurar extamente seguindo as dicas aqui postadas com Floating e também configurando o squid, mas não funciona.

    Vejo que a saída nesse caso seria configurar um Pfsense fazendo o LoadBalance e um segundo Pfsense com o Squid.

    Caso seja essa a solução mais prática, poderiam ajudar como fazer para configurar o segundo Pfsense com o Squid?



  • Amigo,

    Dar uma olhada nesta solução do amigo ccesario..  acho que dar para
    resolver..

    http://forum.pfsense.org/index.php/topic,45232.45.html



  • Fiz as alterações sugeridas no squid.conf e o resultado foi o mesmo. Ao sair pela segunda Wan, no caso, OPT1 o squid bloqueia.



  • @m-storino:

    Fiz as alterações sugeridas no squid.conf e o resultado foi o mesmo. Ao sair pela segunda Wan, no caso, OPT1 o squid bloqueia.

    Não temos relatos de bug neste procedimento. ???

    Você já conferiu:

    • A configuração do squid

    • As regras de firewall com load balance nas floating rules

    • Os nats de saída para a opt1

    • Usou o tcpdump para ver por onde os pacotes estão saindo?



  • Boa tarde meu amigo.

    Já fiz o seguinte:

    –------------------------------------------------------
    Em Firewall>Rules clique na aba Floating

    E criei a seguinte regra:

    Action: Pass
    Interface: Selecione as duas Wans
    Direction: Out
    Source: any
    Destination: any
    Destination port range: 80 ou se nao funcionar coloque a porta do Squid (default 3128)
    Gateway: Selecione o nome da rede LoadBalance que você configurou

    Agora em Firewall>NAT clique na aba Outbound

    Selecione Manual Outbound NAT rule generation e clique em Save

    Mapeie as duas Wans com as seguintes configurações:
    Protocol= any
    Source= any
    Destination= any
    Translation  = Interface address

    Ao final você tera uma regra para cada Wan.

    Configure corretamente Squid Web Proxy em Services>Proxy Server

    Na aba General em Proxy Interface selecione a LAN e loopback.
    Em Custom Options adicione o comando:

    tcp_outgoing_address 127.0.0.1;


    E também segui as orientações do link abaixo que vc mencionou:
    http://forum.pfsense.org/index.php/topic,45232.45.html

    e não funciona.

    Quero enfatizar que o LoadBalance e FailOver estão funcionando perfeitamente. Mas ao habilitar o Squid o mesmo bloqueia as páginas em HTTP porém as páginas em HTTPS navegam normalmente.

    Peço para alguém, se puder ou tiver a solução que por gentileza informe o passo-a-passo, pois estou chegando a conclusão que pelas dicas que foram postadas tem algo a mais que estão esquecendo de informar, ou derrepente é algo óbvio para os experts no assunto que não vale a pena comentar nos posts, mas mesmo assim, para usuários iniciantes em PfSense como eu peço que por favor revisem os procedimentos.



  • @m-storino:

    –------------------------------------------------------
    Em Firewall>Rules clique na aba Floating

    E criei a seguinte regra:

    Action: Pass
    Interface: Selecione as duas Wans
    Direction: Out
    Source: any
    Destination: any
    Destination port range: 80 ou se nao funcionar coloque a porta do Squid (default 3128)
    Gateway: Selecione o nome da rede LoadBalance que você configurou

    Tente pegar somente o trafego do squid, mudando o source de any para 127.0.0.1.

    Não esqueça de usar o tcpdump para diagnosticar qual passo não esta funcionando no seu firewall.


Log in to reply