Wpad para celulares?



  • Boa tarde senhores!

    Agora estou com maaais um pepino nas mãos pra resolver, kkkkkk
    Em um tópico passado eu expliquei que precisei criar uma rede para um colégio, onde o acesso seria restrito para os alunos com controle de horários.
    Usei o WPAD na rede para configurar o proxy a fim de evitar transtorno para alunos e responsáveis da TI.
    Até então tudo perfeito e funcionando "tinindo"..
    Máquinas só acessam com o MAC cadastrado e passando pelo proxy.

    Agora, um problema:
    E os tables/celulares com Android/IOS? Como ficam?
    Procurei de tudo quanto é maneira em foruns nacionais e estrangeiros e não encontrei nada a respeito.
    Alguém sabe de uma solução para tal? Se é possível?

    Caso não seja, o que me recomendariam para contornar essa situação?

    Grato desde então,

    Att.
    Derick Raiocovitch



  • @derickraio:

    Agora, um problema:
    E os tables/celulares com Android/IOS? Como ficam?
    Procurei de tudo quanto é maneira em foruns nacionais e estrangeiros e não encontrei nada a respeito.

    Melhora seus argumentos de pesquisa  ;)
    Pesquisei no google wpad + iphone e encontrei:

    http://www.findproxyforurl.com/iphone_proxy_pac.html



  • @marcelloc:

    @derickraio:

    Agora, um problema:
    E os tables/celulares com Android/IOS? Como ficam?
    Procurei de tudo quanto é maneira em foruns nacionais e estrangeiros e não encontrei nada a respeito.

    Melhora seus argumentos de pesquisa  ;)
    Pesquisei no google wpad + iphone e encontrei:

    http://www.findproxyforurl.com/iphone_proxy_pac.html

    Até ai tranquilo..
    Mas Iphone aqui ainda é minoria.. e para o Android?
    Eu tenho um com ICS e outro com o 2.3.3 e não consigo setar esse tipo de configuração.



  • @derickraio:

    Até ai tranquilo..
    Mas Iphone aqui ainda é minoria.. e para o Android?
    Eu tenho um com ICS e outro com o 2.3.3 e não consigo setar esse tipo de configuração.

    já olhou algum aplicativo no market para isso(proxydroid)?

    http://www.xda-developers.com/android/auto-proxy-for-android-https-socks-and-ntlm/
    http://support.mozilla.org/en-US/questions/866590



  • derickraio,

    Também tive o mesmo problema com o wpad para os diversos tipos de dispositivos… o objetivo era implementar uma solução que disponibilizasse o acesso a internet pela rede sem fio sem maiores dificuldades, apenas um captive portal + autenticação radius. Porém, no meio do caminho veio as dores de cabeça na fase de testes com o wpad:

    Aluno 01: "Ah... meu celular (android, symbian, iphone, xingling) não funciona na rede sem fio..."
    Aluno 02: "Ah... meu tablet não navega..."

    Enfim, por enquanto não estou usando o wpad devido a forças maiores (mais la pra frente quem sabe), sei que perco um pouco o controle com proxy transparente... mas tenho clientes satisfeitos porque seus dispositivos móveis funcionam sem maiores dificuldades pelo serviço sem fio disponibilizado para eles.



  • Fala pessoal, eu to passando pelo mesmo problema no meu trabalho, o cara que fez o firewall não é de lá, ele fez o firewall no pfsense e depois deixou de mão, agora to tentando resolver essa situação principalmente com os smartphones, o pessoal fica falando coisa todo dia, lá o pfsense ta como firewall+squid+squidGuard+wpad, gostaria de saber com vc's se tem uma forma de eu desativar o wpad para ver se resolvia o problema na minha rede, o bom é a segurança q o wpad oferece, mais tb a dor de cabeça é grande, espero que alguem possa me ajudar, obrigado.



  • Não precisa desabilitar o wpad, basta habilitar o transparente do proxy e acabar com a sua segurança abrindo o https para navegação.



  • @marcelloc:

    Não precisa desabilitar o wpad, basta habilitar o transparente do proxy e acabar com a sua segurança abrindo o https para navegação.

    Fala marcelloc, eu ja tinha marcado o proxy tranparent só que mesmo assim não resolveu, como faço para abrir a segurança no https? Obrigado pela ajuda.



  • @fddsp:

    Fala marcelloc, eu ja tinha marcado o proxy tranparent só que mesmo assim não resolveu, como faço para abrir a segurança no https? Obrigado pela

    Cria uma regra na lan liberando https.



  • @marcelloc:

    @fddsp:

    Fala marcelloc, eu ja tinha marcado o proxy tranparent só que mesmo assim não resolveu, como faço para abrir a segurança no https? Obrigado pela

    Cria uma regra na lan liberando https.

    Fala marcelo, ja tinha feito essa regra e não funcionou, o q percebi é que o cara configurou no AD para conectar usando o wpad também então a rede fica presa a ele de toda forma não é isso? Obrigado.



  • @fddsp:

    Fala marcelo, ja tinha feito essa regra e não funcionou, o q percebi é que o cara configurou no AD para conectar usando o wpad também então a rede fica presa a ele de toda forma não é isso? Obrigado.

    O wpad é um serviço que entrega informação mas não remove acesso ou cria regras.
    O wpad é uma configuração que o cliente tem que saber puxar. Se os seus tablets ignoram esta informação, ele vai bater nas regras do firewall.



  • marcelo,

    neste caso então estaria faltando uma regra de nat liberando a rede interna?



  • @dougf4nnie:

    neste caso então estaria faltando uma regra de nat liberando a rede interna?

    Conforme mencionado pelo marcelloc, crie as regras permissivas em "Firewall->Rules-Lan"!



  • @marcelloc:

    @fddsp:

    Fala marcelo, ja tinha feito essa regra e não funcionou, o q percebi é que o cara configurou no AD para conectar usando o wpad também então a rede fica presa a ele de toda forma não é isso? Obrigado.

    O wpad é um serviço que entrega informação mas não remove acesso ou cria regras.
    O wpad é uma configuração que o cliente tem que saber puxar. Se os seus tablets ignoram esta informação, ele vai bater nas regras do firewall.

    É marcelloc, eu tenho que verificar direito as configs do firewall, pois eu fiz a regra de liberar o acesso da lan para https como vc tinha falando anteriormente e tb ja tinha o do http e mesmo assim não funcionou, o squid ta como transparent e os smarts e tablet so consegue entrar na pagina do google(não sei porque só ela) e mesmo assim bem lento. Obrigado mais uma vez a vc e a todos que estão me ajudando.



  • Você ja verificou a ordem das regras e fez alguns tcpdumps para ver que tráfego chega no firewall?



  • @marcelloc:

    Você ja verificou a ordem das regras e fez alguns tcpdumps para ver que tráfego chega no firewall?

    As regras estão nessa ordem:

    Se vc puder me dizer qual o comando que eu rodo para verificar onde a rede esta barrando as maquina eu testo aqui, lembrando que ele ativou o wpad no dhcp do AD, e se caso eu desmarque o proxy ou detectar automatico ele não funciona a net. Obrigado.



  • A sua segunda regra na lan, bloqueia redes não publicadas. Desmarque a opção Block bogon networks na interface lan e testa denovo.



  • @marcelloc:

    A sua segunda regra na lan, bloqueia redes não publicadas. Desmarque a opção Block bogon networks na interface lan e testa denovo.

    Ja desmarquei a opção "Block bogon net" testei mais ainda sim não deu em nada, vi tb q ela ta ativada na interface WAN, desmarco também? Obrigado e desulpa ai as milhares de perguntas porque eu sou novo nesse mundo do pfsense, vlw.


Log in to reply