Squid 3.1.19 no pfsense 2.0.1 com squid_ldap_group



  • Bom dia.
    Depois de algums dias ralando, o porque autenticação por grupos funcionava no squid 2.7 do pfsense 2.01 e não funcionava na versão do squid 3.1.19 o ccesario descobriu o problema do squid 3.1.19 não subir o modulo do squid_ldap_grup.
    Isso ocorre porque o modulo squid_ldap_group por default utiliza ipv6 ao invés de ipv4.
    Então para solucionar basta passar o parametro ipv4  conforme abaixo em negrito.
    external_acl_type ldap_group ipv4 %LOGIN /usr/local/libexec/squid/squid_ldap_group -R -b "dc=agrovale,dc=com,dc=br" -D "cn=root,dc=agrovale,dc=com,dc=br" -w "qistoze." -f "(&(cn=%g)(memberuid=%u))" -h 192.168.1.39 -p 389

    Link referente ao bug.
    http://bugs.squid-cache.org/show_bug.cgi?id=3439



  • Excelente feedback!  :)


Log in to reply