Configuration is lost upon reboot



  • Hi all :)

    First time pfSense user, I have running on an Alix2d3 and am so far quite impressed with it. I do however have a problem which is a major nuisance : the configuration is reset (ie: factory defaults, including admin password etc.) every time I reboot the device…

    I installed the board twice by first booting a linux liveCD via PXE (didn't have a CF reader handy) and dd'ing the image file. This process obviously was somewhat successful as the board would boot, but just that problem of the volatile configuration is getting me :-/

    I tried once with pfSense-2.0.1-RELEASE-512mb-i386-nanobsd.img.gz and once with pfSense-memstick-2.0.1-RELEASE-i386.img.gz – same result. Currently have that first file flashed (nanobsd) and the dashboard shows version number :

    2.0.1-RELEASE (i386)
    built on Mon Dec 12 17:53:52 EST 2011
    FreeBSD pfSense.localdomain 8.1-RELEASE-p6 FreeBSD 8.1-RELEASE-p6 #0: Mon Dec 12 17:53:00 EST 2011 root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8 i386

    Any ideas / pointers / stuff to try and find out why would be greatly appreciated :)

    Best regards,

    • Thomas

    EDIT: Adding output of 'mount' command :

    $ mount
    /dev/ufs/pfSense on / (ufs, local, read-only)
    devfs on /dev (devfs, local)
    /dev/md0.uzip on /usr (ufs, local, read-only)
    /dev/md1 on /tmp (ufs, local)
    /dev/md2 on /var (ufs, local, noatime)
    /dev/md3 on /etc (ufs, local, noatime)
    /dev/md4 on /usr/local/etc (ufs, local, noatime)
    /dev/md5 on /conf (ufs, local)
    /conf on /cf/conf (nullfs, local)
    /dev/md6 on /home (ufs, local)
    <above>:/tmp/unionfs/usr on /usr (unionfs, local)
    <above>:/tmp/unionfs/root on /root (unionfs, local)
    <above>:/tmp/unionfs/bin on /bin (unionfs, local)
    <above>:/tmp/unionfs/sbin on /sbin (unionfs, local)
    <above>:/tmp/unionfs/boot on /boot (unionfs, local)
    <above>:/tmp/unionfs/confdefault on /conf.default (unionfs, local)
    devfs on /var/dhcpd/dev (devfs, local)</above></above></above></above></above></above>


  • Netgate Administrator

    The nanobsd image is the one you want. The memstick image is for installing to a hard drive.
    However the output from your 'mount' command looks very odd if it's from the Nano image.
    Here's mine:

    
    [2.0.1-RELEASE][root@pfsense.fire.box]/root(7): mount
    /dev/ufs/pfsense0 on / (ufs, local, noatime, read-only, synchronous)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    /dev/ufs/cf on /cf (ufs, local, noatime, read-only, synchronous)
    devfs on /var/dhcpd/dev (devfs, local)
    
    

    Your filesystem appears to be using a memory disk (md5) as /conf, hence it forgets the config everytime you turn it off.
    I suggest you try to find a CF reader, format the card and start again.  ;)

    Steve



  • Yeah that appears you're running memstick which is the flash version of the iso, not nanobsd. Only nanobsd will save the config, memstick is exactly like booting from CD (CD/memstick contents will not be changed).



  • Thank you both for your replies.

    You were both right, somehow when flashing for the second time I forgot the '-O-' argument to wget, meaning nothing was really written to the CF card :-[ I just flashed it correctly and it works like a charm!

    Sorry for wasting your time… At least I learned what /dev/mdX stands for ^^ (I'm fluent in linux but have zero *bsd experience...)

    Best,

    • Thomas

Log in to reply