Need som help configurating Pfsense. Bridge mode? VPI? VCI?



  • I have a Norwegain ADSL Company called Bluecom. I called them and they said that the router had to be configurated like this:

    Bridging mode have to be active
    VPI have to be "37"
    VCI have to be active

    How do I do this with PFsense?

    In my 3com router the default settings is "Dynamic IP" and bluecom told me that I didn't have to change it. In Pfsense that option is not there, only "Static Ip adress" and PPPoE, PPPT etc. Any clues?

    For the record… I have to experince with Pfsense at all, but Im learning ;)



  • VPI and VCI are options for the DSL-Modem afaik. You have to enter these there. pfSense doesn't support build in modems. You have to utilize a modem at the WAN interface of your pfSense for this.



  • Thanks for replying. U have to explain a little deaper. I have a regular dsl modem. There goes a wire from the modem to one of the lan-interfaces. What do you mean by "Built in modems"? And where can I find DSL-Modem afaik?



  • It should look like this:

    providerline–------DSL-modem-------WAN/pfsense/lan-----your network

    The VCI and VPI settings should be found in the webgui of your DSL Modem. That setting is not pfSense specific. If that modem has worked with another router before don't touch these settings. The pfSense WAN has to be configured for PPPoE dialup if you have login user and password from your provider. If you have a static IP assigned by your provider just use static with the settings (IP and gateway) you got from them. If that isn't the case your WAN should be set to DHCP as your provider then most likely assigns your adress by DHCP. It's provider specific.



  • "providerline–------DSL-modem-------WAN/pfsense/lan-----your network"

    Its like that.

    But Bluecom told me that VPI and VCI shoud be configurated in the router, and I don't think the modem has a firmware, no way of entring it. The modem has not worked (as I know) on any other routers. I Have this 3com router, but I cant find VPI and VCI there either so I desided to rather make Pfsense work instead. Bluecom has no entring password or username. If I plug the cable from the modem and right into the computer, I have internett without any configurating or software installing.

    Do every DSL-providers have and IP adress? And what is actually DHCP? I thought that was a server that proveded the network with its own IP-adresses (for example 192-168.1.xxx)?



  • VPI/VCI is a function of you're modem, not pfSense.



  • No IP = no internet. Yes, every provider has IPs.
    And the way you describe it it should just work in factory default settings of the pfsense as it has DHCP on wan by default. Try to powercycle the modem. Some providers have issues with assigning IPs when the MAC address of the networkcard they see has changed.



  • I see… But what about bridging mode? Is that a deafult function? And what is Powercycle?

    Last thing about these VPI and VCI. Do this have to be correct to have internett at all? Cuz I have interett if a plug the cable from the modem to my computer, do this mean that VPI and VCI are correct?

    What about DNS adresses? Leave these open or set the adress that I got from Bluecom? Shoud I do anything with the MAC adress? If Im remembering correctly, PFsense had an opening for writing down and MAC adress somwhere :P



  • If it works with your computer directly connected you don't have a VCP VPI issues. Powercycle means unplug power and replug it. switch off and on. Leave it unpowered for some time (1 minute or so). If your provider has given you DNS adresses enter them at system>general and leave the option "allow DNS ser list to be overridden…" checked.



  • Thanks for all the help! Pfsense is "configurated" and the internet is up and running :D



  • Thanks for all the help! The internet is now up and running :D

    But I have a question. Where can I block/unblock programs such as p2p programs, msn messenger etc? Cuz it seems like MSN messenger is blocket :S The internet is working fine, but not msn :(



  • msn messinger shoud work
    it uses port 80 just like the websites
    only for cam and sound it needs poorts from the wan site to be opend to the ipadress on the lan site
    you use port forwarding on the nat tab for that
    same with p2p u need poorts from the wan site of pfsense to be opend to youre pc
    olso you need to be opening those poorts on you windows pc firewall

    you can only open those poorts to 1 pc on youre network
    so 2 pc's with edonkey on the same poorts is not goining to work



  • @jeroen234:

    msn messinger shoud work
    it uses port 80 just like the websites
    only for cam and sound it needs poorts from the wan site to be opend to the ipadress on the lan site
    you use port forwarding on the nat tab for that
    same with p2p u need poorts from the wan site of pfsense to be opend to youre pc
    olso you need to be opening those poorts on you windows pc firewall

    you can only open those poorts to 1 pc on youre network
    so 2 pc's with edonkey on the same poorts is not goining to work

    Exactly, you now have a firewall that blocks unwanted connections from the outside (looks like you had no firewall before from what I can read from the above discussion). You have to tell it that this is a connection you want to pass.



  • To enable voice and video communications with Windows Messenger through a non-UPnP firewall, configure the firewall to allow incoming traffic on UDP ports 5004 – 65535.

    For other purposes, enable the following ports:

    File Transfer: tcp 6891 (to allow 10 simultaneous file transfers open ports 6891 through 6900)

    Application and Whiteboard Sharing: tcp 1503

    Remote Assistance: tcp 3389


Locked