RDP Wont work



  • So I port forwarded 3389 from WAN to internal windows server that I want to remote into.

    Local remote works fine. Outside does not. It tries to connect, makes it somewhat through and disconnects and I get a "Can not connect to windows based machine because of network issues". Not the exact message but you get the point.

    Now, my outbound is set to MANUAL because thats the only way my 2 xbox's and 2 pc's with BF3 will work. If its automatic, both xbox's are STRICT or Moderate/Strict. Right now both are OPEN. BF3 wont work AT ALL, one or the other can connect, both CANT.

    I have a buddy who swears his works perfectly fine. Although ive never seen him and his brother play xbox or pc at the same time like my situation, but he's on automatic and he says it works perfectly fine.

    Also, I tried setting up Cisco IPSEC, copied his settings which worked on his iPhone and mine, but my settings wont work on neither.

    Does it sound like I have a corrupt pfsense config? I've reinstalled pfsense so many times because of stupid issues, but I havent in over 6 months because I figured out the multiple lan thing where now I can have any amount of PC's or xboxs on the network, all open, all can lan and play fine.

    What should I do?

    Thanks,
    Sikh



  • Some people mess things up to the extent they just reinstall rather than fixing it, but short of massive problems that leave nothing working, your config isn't corrupt. Nothing would work if that were the case and you would have all kinds of ugly errors.

    The port forward, first guess is Windows firewall on the host itself, which commonly only allows local subnet to RDP by default. Other troubleshooting steps:
    http://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    The IPsec, no idea, you'll have to post details on that, in a separate thread under IPsec.



  • When trying to use RDP, set pfSense to log connections for the port and then try to connect while logged into the firewall and see what happens, if you cant do both at the same time then while at the location go to grc.com from any computer there and under services click shieldsup!, scroll down and click proceed and then type in the port that you want to see the status of (open,closed,stealth), in this case 3389 and click "User Specified Custom Port Probe". If it says you failed then you have succeeded, the port is open to all to see.

    Things that could be blocking RDP from working in addition to what CMB has stated:
    Snort
    Firewall port forward rule incorrect
    IP address of the system you want to RDP to has changed


Log in to reply