Not Found 404 - LightSquid



  • Oi Pessoal, mais uma vez aqui, pedindo ajuda de vocês.
    Então, squid tá rodando legal com squidGuard, porém hoje, ao instalar o LightSquid pros relatórios de acesso, depois de configurá-lo, quando cliquei em Report, me apareceu o erro 404.

    Na configuração proxy report, ele pede para que os logs do squid fiquem no diretorio: /var/squid/log
    ok, antes de instalar estava.
    Logo após a instalação do LightSquid, o diretório passou a ser /var/squid/logs

    Eu já tentei modificar manual, mas qdo reinicio o firewall, volta a ficar /var/squid/log e o erro persiste

    Ele tá buscando os logs onde não existem, deve ser por isso.

    Alguém já teve um problema desse, que possa me ajudar?



  • Este eh um erro reportado e teoricamente ja corrigido pelo mantenedor do pacote.

    Voce pode tentar resolver isso configurando o log do squid na pasta que o lightsquid busca ou alterar o arquivo inc do lightsquid para ele buscar na pasta correta.



  • Tive um problema parecido. No meu caso, ao acessar os logs do Lightsquid só dava aquela tabelinha de erro do cgi, pedindo pra rodar o lightparser.pl pra ver o que havia de errado. Eu rodei e vi que o erro era o caminho que o Lightsquid tava tentando buscar o access.log, ele tava buscando na pasta /var/squid/logs, aí eu procurei e encontrei o arquivo que indica este caminho errado. Basta editar o arquivo /usr/local/etc/lightsquid/lightsquid.cfg e alterar o caminho pro diretório do access.log. Pronto, depois é só rodar o lightparser.pl que ele gera os relatórios certinhos.



  • @epboeira:

    Tive um problema parecido. No meu caso, ao acessar os logs do Lightsquid só dava aquela tabelinha de erro do cgi, pedindo pra rodar o lightparser.pl pra ver o que havia de errado. Eu rodei e vi que o erro era o caminho que o Lightsquid tava tentando buscar o access.log, ele tava buscando na pasta /var/squid/logs, aí eu procurei e encontrei o arquivo que indica este caminho errado. Basta editar o arquivo /usr/local/etc/lightsquid/lightsquid.cfg e alterar o caminho pro diretório do access.log. Pronto, depois é só rodar o lightparser.pl que ele gera os relatórios certinhos.

    Estou com o mesmo problema, tem fiz essa alteração mas não resolveu.



  • @veniciopika:

    @epboeira:

    Tive um problema parecido. No meu caso, ao acessar os logs do Lightsquid só dava aquela tabelinha de erro do cgi, pedindo pra rodar o lightparser.pl pra ver o que havia de errado. Eu rodei e vi que o erro era o caminho que o Lightsquid tava tentando buscar o access.log, ele tava buscando na pasta /var/squid/logs, aí eu procurei e encontrei o arquivo que indica este caminho errado. Basta editar o arquivo /usr/local/etc/lightsquid/lightsquid.cfg e alterar o caminho pro diretório do access.log. Pronto, depois é só rodar o lightparser.pl que ele gera os relatórios certinhos.

    Estou com o mesmo problema, tem fiz essa alteração mas não resolveu.

    Muito estranho… pra mim resolveu.

    Só que agora, depois de fazer algumas alterações (dns e dhcp pra aparecer o nome das máquinas no relatório) fui rodar de novo o lightparser.pl e ele deu novamente o mesmo erro, dizendo que não encontrava o diretório onde os logs estavam. Fui ver no lightsquid.cfg e vi que o arquivo voltou pro caminho anterior, o errado.

    Onde eu posso trocar a configuração pra que ele mantenha a configuração certa? Se não vou ter que trocar toda vez que precisar rodar/atualizar os relatórios.

    Veniciopika, lembre que você tem que rodar o lightparser.pl pra que ele gere os relatórios. Só trocar o caminho no arquivo .cfg não adianta. Tem que trocar o caminho e rodar o arquivo.



  • @epboeira:

    @veniciopika:

    @epboeira:

    Tive um problema parecido. No meu caso, ao acessar os logs do Lightsquid só dava aquela tabelinha de erro do cgi, pedindo pra rodar o lightparser.pl pra ver o que havia de errado. Eu rodei e vi que o erro era o caminho que o Lightsquid tava tentando buscar o access.log, ele tava buscando na pasta /var/squid/logs, aí eu procurei e encontrei o arquivo que indica este caminho errado. Basta editar o arquivo /usr/local/etc/lightsquid/lightsquid.cfg e alterar o caminho pro diretório do access.log. Pronto, depois é só rodar o lightparser.pl que ele gera os relatórios certinhos.

    Estou com o mesmo problema, tem fiz essa alteração mas não resolveu.

    Muito estranho… pra mim resolveu.

    Só que agora, depois de fazer algumas alterações (dns e dhcp pra aparecer o nome das máquinas no relatório) fui rodar de novo o lightparser.pl e ele deu novamente o mesmo erro, dizendo que não encontrava o diretório onde os logs estavam. Fui ver no lightsquid.cfg e vi que o arquivo voltou pro caminho anterior, o errado.

    Onde eu posso trocar a configuração pra que ele mantenha a configuração certa? Se não vou ter que trocar toda vez que precisar rodar/atualizar os relatórios.

    Veniciopika, lembre que você tem que rodar o lightparser.pl pra que ele gere os relatórios. Só trocar o caminho no arquivo .cfg não adianta. Tem que trocar o caminho e rodar o arquivo.

    então foi isso que fiz, em estou enviando meu arquivo em anexo tem como vc dar uma olhada para min?

    arquivo.txt



  • @epboeira:

    @veniciopika:

    @epboeira:

    Tive um problema parecido. No meu caso, ao acessar os logs do Lightsquid só dava aquela tabelinha de erro do cgi, pedindo pra rodar o lightparser.pl pra ver o que havia de errado. Eu rodei e vi que o erro era o caminho que o Lightsquid tava tentando buscar o access.log, ele tava buscando na pasta /var/squid/logs, aí eu procurei e encontrei o arquivo que indica este caminho errado. Basta editar o arquivo /usr/local/etc/lightsquid/lightsquid.cfg e alterar o caminho pro diretório do access.log. Pronto, depois é só rodar o lightparser.pl que ele gera os relatórios certinhos.

    Estou com o mesmo problema, tem fiz essa alteração mas não resolveu.

    Muito estranho… pra mim resolveu.

    Só que agora, depois de fazer algumas alterações (dns e dhcp pra aparecer o nome das máquinas no relatório) fui rodar de novo o lightparser.pl e ele deu novamente o mesmo erro, dizendo que não encontrava o diretório onde os logs estavam. Fui ver no lightsquid.cfg e vi que o arquivo voltou pro caminho anterior, o errado.

    Onde eu posso trocar a configuração pra que ele mantenha a configuração certa? Se não vou ter que trocar toda vez que precisar rodar/atualizar os relatórios.

    Veniciopika, lembre que você tem que rodar o lightparser.pl pra que ele gere os relatórios. Só trocar o caminho no arquivo .cfg não adianta. Tem que trocar o caminho e rodar o arquivo.

    então foi isso que fiz, em estou enviando meu arquivo em anexo tem como vc dar uma olhada para min?

    arquivo.txt



  • Veniciopika, dei uma olhada no teu arquivo de configuração, tá faltando apontar o local correto do arquivo access.log.

    Você tá apontando pro mesmo diretório dos relatórios. O correto é apontar pro diretório onde está o arquivo access.log. Geralmente está em /var/squid/log (ou logs).

    Então edita ele e coloca o caminho correto que vai funcionar.

    • obs. Se você incluiu essa linha, ao invés de editar, pode ser porque lá na configuração do squid você não marcou pra ele gerar os logs (Enable Logging).


  • Vou postar a parte do meu arquivo de configuração pra você ver como ficou:

    # -------------------- GLOBAL VARIABLES  ---------------------------
    
    #path to additional `cfg` files
    $cfgpath = "/usr/local/etc/lightsquid";
    #path to `tpl` folder
    $tplpath = "/usr/local/www/lightsquid/tpl";
    #path to `lang` folder
    $langpath = "/usr/local/share/lightsquid/lang";
    #path to `report` folder
    $reportpath = "/var/lightsquid/report";
    #path to access.log
    $logpath = "/var/squid/log";
    #path to `ip2name` folder
    $ip2namepath = "/usr/local/libexec/lightsquid";
    
    

Locked