Second WAN not listed on Load Balancer - 1.2-BETA-1-TESTING-SNAPSHOT-05-04-07



  • I upgraded this firmware this morning. Most things are working fine, I like the changes, except my second WAN connection is not listed any longer on the Load Balancer page.

    I was having some issues load balancing, so I checked the configuration. Both WAN and WAN2 were listed, and both were "UP". I removed them both and tried to re-create, except now WAN2 isn't listed in the dropdown.

    Wha?



  • I'm also not seeing WAN2 as a possible gateway on any rule.

    On the Load Balancer, when I click the Virtual Servers tab, I get:
    Warning: Invalid argument supplied for foreach() in /usr/local/www/status_slbd_vs.php on line 77



  • I rolled back to 1.2-BETA-1-TESTING-SNAPSHOT-05-02-07, and I'm getting it here also.

    Later in the day I'll roll back to pfSense-Full-Update-1.2-BETA-1-TESTING-SNAPSHOT-04-30-07, where things were working fine.



  • OK… so now I'm confused. I've wiped my install and set up 1.2 BETA 1 (no snapshots). I restored my configuration, and again, WAN2 not available... I'll wipe once more, and before I restore my config I'll check to see if WAN2 is available on the Load Balancer screen.

    Any ideas?



  • Install the latest version.  Note/copy /tmp/rules.debug somewhere.

    Now roll back to a working solution.  What is different in /tmp/rules.debug?  Please save both configurations (working and non-working).

    Send me both configurations properly labeled (this one works, this one does not) and we can do a diff on the 2 configurations.

    sullrich@gmail.com



  • Ha… so I loaded Beta 1, checked it out, and it gave the same issue. I went and created an outbound NAT rule for both connections, and now both gateways show up again... wierd. I'm going to save this config, and restore my old one, and see if something happened to the NAT rules. I know I've created them all before though.

    Tell me, when I select Automatic rule generation, I can also add rules manually. Does this mean the best of both worlds... or what?



  • Loaded the old config, removed all the NAT rules, re-created them like I just did now… still doesn't work. So wierd. I'm now restoring pieces of my original configuration onto the working config.

    Update: Alright, so I've restored the bits of the configuration I didn't want to have to re-enter (aliases, rules etc.) and now things are working fine again. I can only assume that something was messed with my configuration file. I've compared both configurations, and while I can't see any gaping issues, there are various discrepancies, mostly in the formatting of the XML. I wonder if my configuration became corrupt, or if there are some small changes between 1.1 and 1.2 that I got caught up on.


Log in to reply