FreeRADIUS



  • Sorry if this has been posted, or if I’m just missing something and it’s not a 2.1 bug, but I can’t get FreeRADIUS (1 or 2) to start on the latest 2.1 snapshot:

    2.1-DEVELOPMENT (i386)
    built on Wed May 2 08:30:32 EDT 2012



  • No .pbi packages exists for these two freeradius packages till now.
    At the moment it is only possible to use them with pfsense 2.0.0 and 2.0.1

    I am sure there will be some for pfsense 2.1 but this needs some time.



  • Thank you very much, I didn’t realize there was a difference from 2.0 to 2.1 🙂 What’s involved in creating such a package, and would it be possible to manually convert the current packages? I’m not too familiar with FreeBSD, but I’m thinking something along the lines of the alien program for Linux which converts between the common package manager types.

    Thanks!

    Mark



  • a pbi package is a container which contains all dependencies freeradius2 needs. this prevents conflicts between other packages with different versions like perl or something else.

    The problem with freeradius2 will be that the package is compiled with different options like LDAP, kerberos, mysql, and so on. So you probably need to recompile them first.
    Further pfsense 2.0.x uses freebsd 8.1 and pfsense 2.1 uses freebsd 8.3. So there is no way around to recompile everything on 8.3 basis.

    Hope this will help you to understand 😉



  • Thanks! Hopefully someone makes one for 2.1 🙂


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy