Unable to communicate with www.pfsense.com



  • Fresh install of 2.0-RELEASE, and when I go to Availible Packages, I get the following error message:
    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    Thanks,

    Sri



  • On the pfsense GUI go to Diag -> DNS lookup and see if you can resolve www.pfsense.com.



  • Hello,

    I have the same issue. When I go to packages, available packages I get "unable to communicate with www.pfsense.com" error. On a shell console, with links www.pfsense.com, the index page is displayed but with a high loading time (it took almost a minute to finish loading on a 100MB connection).

    DNS lookup from web GUI on www.pfsense.com:

    DNS lookup from web GUI on www.pfsense.org:

    Please help!

    Thank you,

    Nick



  • Can you get to it today? Do you have any packages installed? (squid, dansguardian, squidguard … etc)



  • Hello,

    Thank you for your answer. No I still can't get to it … I have no packages installed. This is a default installation.



  • In general settings where you have the DNS configured, do you have a gateway set? All mine are not set and I don't have any issues like that.



  • The DNS servers have NONE as gateway. I don't think that the DNS is the issue. pfsense.com is a round robin or something similar for pfsense.org and pfsense.org resolves correctly. It must be something else … maybe the pfsense guys are blocking IP addresses/classes?



  • They are probably only blocking private IPs and bogons. Can you get to www.pfsense.com or updates.pfsense.org or snapshots.pfsense.org from a browser?



  • Yes I can open all three from a different PC on the same network.



  • Have you modified your outbound NAT rules?



  • No. The only rules I have are the port forwarding ones. No 1:1 and no Outbound NAT. DNS forwarder has some hosts added but they are local …



  • Can you traceroute from the pfsense gui and see how far it gets?



  • Trace result for www.pfsense.com :

    
    Traceroute output:
    
     1  10.0.0.1 (10.0.0.1)  1.563 ms  1.590 ms  3.206 ms
     2  10-112-120-17.private.brasov.rdsnet.ro (10.112.120.17)  2.043 ms  1.186 ms  1.610 ms
     3  qr91.brasov.rdsnet.ro (213.154.145.110)  4.092 ms  1.782 ms  2.119 ms
     4  br01.budapesta.rdsnet.ro (213.154.124.42)  16.241 ms
        br01.budapesta.rdsnet.ro (213.154.125.80)  15.067 ms
        br01.budapesta.rdsnet.ro (213.154.124.46)  15.303 ms
     5  dialup-212.162.26.129.frankfurt1.mik.net (212.162.26.129)  15.488 ms  15.816 ms  15.388 ms
     6  ae-0-11.bar1.Budapest1.Level3.net (4.69.141.241)  23.568 ms  15.601 ms  15.572 ms
     7  4.69.141.250 (4.69.141.250)  31.023 ms  31.187 ms  32.136 ms
     8  ae-47-47.ebr2.Paris1.Level3.net (4.69.143.142)  40.147 ms
        ae-46-46.ebr2.Paris1.Level3.net (4.69.143.138)  39.637 ms
        ae-45-45.ebr2.Paris1.Level3.net (4.69.143.134)  39.630 ms
     9  ae-43-43.ebr2.Washington1.Level3.net (4.69.137.58)  117.827 ms
        ae-42-42.ebr2.Washington1.Level3.net (4.69.137.54)  120.639 ms  120.582 ms
    10  ae-72-72.csw2.Washington1.Level3.net (4.69.134.150)  119.293 ms  122.298 ms
        ae-92-92.csw4.Washington1.Level3.net (4.69.134.158)  118.830 ms
    11  ae-71-71.ebr1.Washington1.Level3.net (4.69.134.133)  121.929 ms
        ae-61-61.ebr1.Washington1.Level3.net (4.69.134.129)  121.729 ms
        ae-71-71.ebr1.Washington1.Level3.net (4.69.134.133)  119.239 ms
    12  ae-2-2.ebr3.Atlanta2.Level3.net (4.69.132.85)  132.795 ms  131.355 ms  131.469 ms
    13  ae-73-73.ebr2.Atlanta2.Level3.net (4.69.148.254)  132.501 ms  135.469 ms  132.803 ms
    14  ae-8-8.car1.Nashville1.Level3.net (4.69.140.229)  327.997 ms  207.828 ms  254.008 ms
    15  ae-11-11.car2.Nashville1.Level3.net (4.69.140.225)  141.676 ms  141.377 ms  141.981 ms
    16  ae-2-2.car2.Louisville1.Level3.net (4.69.140.221)  144.259 ms  143.807 ms  143.917 ms
    17  ae-11-11.car1.Louisville1.Level3.net (4.69.140.217)  142.531 ms  142.507 ms  145.124 ms
    18  BLUEGRASSNE.car1.Louisville1.Level3.net (4.59.184.6)  147.579 ms  146.762 ms  146.479 ms
    19  * * *
    20  * * *
    
    


  • okay .. open up ssh console and start a tcpdump on your wan. The try to get the packages and see if the traffic is leaving the WAN interface and what the source and destination is.



  • I had the same issue… In my case my WAN port was enabled for DHCPv6, but the router not correctly configured to have DHCPv6 connectivity. I disabled DHCPv6 on the WAN interface, and everything worked...



  • Yes yes yes! I've been having problems with my Board. Gigabyte GA-C1007UN-D. First the WAN wasn't working, I had to manually ifdown and then ifup it. Then EVERYTHING behind the router could access the internet, but not the router itself. Turns out,  THIS. Completely disable IPV6 and you're good to go.



  • Hi friends

    I had dona a installation and configuration of pfsense 2.1(i368). it's working fine but further initial  configurations are like DNS, IP assigning, interface assigning.. almost completed.

    when i go to the available package it showing error like :

    Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity.

    I have check traceroute diagonstics  of www.pfsense.com, it's nothing get result.

    I don't know weather LAN to WAN internet is connecting or not ?

    my pfsense settings :

    pfsense stacture like :  "ISP <=> MODEM <=> WAN <=> pfsense <=> LAN <=> switch"

    ISP : Static IP :183...32

    WAN : 192..1 to 192...254  (Using DHCP)

    LAN : 192...1 to 192..*.254  (Using Static /Not using DHCP )

    When i have checking the ping option :

    LAN to LAN of IP's are ping

    LAN to WAN of IP's are ping

    WAN to WAN of IP's are ping

    WAN to LAN of IP's are not ping

    I have Attached a screenshot. kinly check it.

    I'm beginner of the pfsense, i googled the how to setup & configuration of  pfsense, but i could not implement the my network settings.

    I have mention above the my pfsense  stacture network settings.

    please reply me …...










  • Today I tried to download a package on my pfsense with version 2.1 and it failed with the same error message as mentioned above. Looking into the trace of the communication, it looks like pfsense have moved something on their server.
    The HTTP POST is answered with a "404 Not found".

    I tried to locate the packages myself, without success. Where did they go?

    Can you please check what is wrong?

    Attached the capture file. [0_1551277271726_packetcapture (1).cap](Uploading 100%)


  • LAYER 8 Global Moderator

    @carriest said in Unable to communicate with www.pfsense.com:

    pfsense with version 2.1

    Dude that version is long since dead.. No your not going to be able to get any packages for that version. You should update your pfsense to current 2.4.4p2

    2.1 came out in 2013.


  • Banned

    @carriest said in Unable to communicate with www.pfsense.com:

    Today I tried to download a package on my pfsense with version 2.1 and it failed with the same error message as mentioned above.

    Version 2.1 is looooong dead, I doubt you will get any packages for it anymore.

    Be responsible and update to 2.4.4p2, as this is the only supported version at the moment. This will also get rid of many security issues.


  • Rebel Alliance Netgate Administrator

    Going to lock this thread.

    There is nothing to download on anything but the latest version; this includes Packages.


Log in to reply