LightSquid and sqstat



  • Hello Guys,

    Yesterday evening, I've updated to LightSquid v1.8.0 pkg v.2.32 to enable sqstat.  While sqstat now works beautifully, my LightSquid reports stopped updating (from the time I updated the package, I assume) for whatever reason.

    As of now the LightSquid pages display, but only the data upto yesterday is recorded.  I've tried reinstalling the package, and clicking on "Refresh full" to no avail.

    I have cachemgr.cgi running too, but it works fine just like sqstat.

    My existing logs folder is /var/squid/log and it shows a log file there which is dated today (22 May 2012).

    Any ideas what might be the problem?



  • Work LightSquid and sqstat independent of each other. Which version pfsense you are using ?
    Check the settings for squid log and save it again. Maybe squid does not generate a log.



  • Hi,

    I am using pfSense v2.0.1.

    Squid generates logs at /var/squid/log with latest entries dated today.  Looking at /var/lightsquid/report only shows me files and folders upto yesterday.

    As a package, sqstat got installed together with LightSquid.  I don't understand what you mean by working them independently, sorry…

    Been running LightSquid for a few months now with no problems. :)



  • Try to change /var/squid/log to /var/squid/logs in squid package, then Refresh Lightsquid ( squid must work some time )

    I don't understand what you mean by working them independently, sorry…

    Sorry for the Google translator. I meant that the work of the lightsquid does not depend from the  sqstat.



  • You are right!

    I saw the lightsquid.cfg and it now expects logs from /var/squid/logs!

    For many months now, I've been using /var/squid/log by default and everything worked dandy then…

    Now, I just copied the old log files to /var/squid/logs, pointed squid logging there and did a "Refresh full" on lightsquid settings.  Works now!  Thanks! :)



  • Great!

    Path /var/squid/logs is default for current squid version, but previous LS used '/var/squid/log' as path.
    Now this issue must be fixed.



  • Hi sir i have same problem like this my lightsquid stop on updating. how can i edit the /var/squid/log to /var/squid/logs and where?



  • @jesther24:

    Hi sir i have same problem like this my lightsquid stop on updating. how can i edit the /var/squid/log to /var/squid/logs and where?

    Services  > Proxy server > Log store directory

    Usually, after pkg installation need to check and save pkg settings. It seems this was not done.



  • it takes time to save the path from /var/squid/log to /var/squid/logs



  • ^^You mean copying the log files?  The time depends on the size of the files.  I copied mine using an ssh session to the box, and it took only a couple of minutes.



  • How does everyone have their squid log rotation configured?  Or do squid or lightsquid manage the log automatically?

    For example, I had to copy all the files from my /var/squid/log folder to my /var/squid/logs folder.  However, I've noticed in the /logs folder I have a series of files named:

    access.log – THIS file is 100 MB+.  Is this normal?
    access.log.0 - access.log.6 - ranging from 9 MB to 22 MB each

    and

    cache.log - only about 726k
    cache.log.0 - cache.log.6 - ranging from 680 bytes to just over 1k each

    Thanks in advance.



  • My log rotation is at 7 days.  The typical size of my access.log is at 70MB+ on a good day.

    If you have a lot of users doing web browsing, then your 100MB access.log would be normal. :)



  • @josekym:

    My log rotation is at 7 days.  The typical size of my access.log is at 70MB+ on a good day.

    If you have a lot of users doing web browsing, then your 100MB access.log would be normal. :)

    Incidentally, I only have (2) users in the house so my log file is probably unusually large or isn't rotating as it should be.  Somehow i thought Lightsquid had a built-in log rotate function, but perhaps not.  Where/how do you specifically configure your log to rotate x number of days?  Thanks for your help.



  • So, sorry! I am only able to answer now…  ;D

    Log rotation is set under Squid (i.e. Proxy Server). Go to Services->Proxy Server->General->Log rotate.


Log in to reply