"Sun Jun 3 15:51:36 EDT 2012" build Login page date() warning etc.



  • I'm getting the following at the the login pages, and no background image:

    Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /etc/inc/authgui.inc on line 200

    Also I can no longer log in from my iPhone, I just go back to the login screen.



  • There was some broken PHP causing it, I did send a message to the mailing list and it's now resolved.



  • which is using php version?



  • code, not PHP binary



  • I just upgraded to pfSense-Full-Update-2.1-DEVELOPMENT-i386-20120604-1115.tgz today and am still seeing something similar in the version section after cheking for upgrades.

    Any ideas?

    Thanks!



  • jimp's addition of:
    require_once("config.inc");
    to gwlb.inc on 3 Jun 2012 would have fixed the OP's original issue with the use of the date() function in gwlb.inc

    weekleyj,
    What date warning message are you getting?



  • I get this after the version checking has completed in the version section of the dashboard:
    Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 313 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 313 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 313 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /etc/inc/gwlb.inc on line 313 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /etc/inc/auth.inc on line 1413 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /etc/inc/gwlb.inc:287) in /etc/inc/auth.inc on line 1304 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 47 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 48 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 49 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 50 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 51
    You are on the latest version.



  • gwlb.inc does have the require:
    require_once("config.inc");



  • The require_once might need to go inside the return_gateways_status() function.
    I'll be with my test box in an hour or 2, so I'll try this out with the 20120604-1115 build.



  • I installed http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/nanobsd/pfSense-2.1-DEVELOPMENT-2g-i386-nanobsd-20120604-1116.img.gz on my test Alix system. The wizard went fine. Then the Version section of the status page found an even newer build (seem to be interesting changes every few hours these days:). I went did the update online, first time it fails to install because I always forget to go and check System:Firmware:Settings "Unsigned images" on a new install - I need to put this on my standard checklist of things to set as soon as I boot a new image! 2nd download and it has updated fine. Now I am running:
    2.1-BETA0 (i386)
    built on Mon Jun 4 17:06:08 EDT 2012
    FreeBSD 8.3-RELEASE-p2

    This snap has the recent "Also include gwlb.inc in interfaces.inc" commit in it.
    So far no date() messages on the GUI or in /tmp/PHP_errors.log

    weekleyj, I guess your configuration has something more than my basic fresh test system with 1 WAN and 1 LAN. It must be following different code paths that send it through the date() calls in a way that brings up the warning messages. If it still happens after installing the 17:06 build then it will need more investigation.



  • pfSense-Full-Update-2.1-DEVELOPMENT-i386-20120604-1705.tgz

    2.1-BETA0 (i386)
    built on Mon Jun 4 17:06:41 EDT 2012
    FreeBSD 8.3-RELEASE-p2
    Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /etc/inc/gwlb.inc on line 287 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in /etc/inc/gwlb.inc on line 287 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /etc/inc/auth.inc on line 1413 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /etc/inc/gwlb.inc:287) in /etc/inc/auth.inc on line 1304 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 47 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 48 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 49 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 50 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/gwlb.inc:287) in /usr/local/www/guiconfig.inc on line 51



  • Looks like it was fixed with the last update, Phil.  Thanks for your help!


Locked