LiveCd won't boot



  • Hello everyone.
    I've got a very silly/brickwall situation i'm trying to get around-

    I have been using pfSense for about a year now on a Dell PowerEdge 1750 and it works as smooth as smooth can get.

    I am trying to now install it on another PE 1750-

    Should be easy right? There are a bunch of ways to install.
    Well, PE1750 has no support to boot from usb.
    So i burned the livecd.
    Even though the bios is set up to boot from cd, it totally ignores it.

    Then i thought there must be something wrong with my image/burn. I went ahead and got two other copies from two different mirrors.
    Same result.

    In these circumstantes i'd give the fault to the cd drive or bios but other cds boot just fine.
    Tried ubuntu. Boots. Tried memtest, boots. Acronis too. Even a WinXp cd booted.
    All but my burned pfSense-2.0.1-RELEASE-i386.iso

    Am i missing something here?
    I mean, with the same hardware, in the past, i didn't have these issues?

    Thanks in advance to anyone trying to shed some light into this.


  • Netgate Administrator

    First thing is check that your pfSense CD boots in something else, check that the image is actually on the CD correctly.
    Those Dell servers with laptop style optical drives seem incredibly fussy about booting live CDs for some reason. If you search the forum there are many other people with similar stories. There doesn't seem to be any special trick to making them work unfortunately. If you find a brand of media it likes it will boot. Some people have swapped out the drive and had no problems.  :-\

    Steve



  • I suggest you clone the hard drive in the PE1750 currently running pfSense and install the cloned drive in the new PE1750.

    If you can afford some down time on your current pfSense you could boot a Linux live CD and dd the existing pfSense hard drive to the hard drive for the new PE1750. If you can't afford down time and you have a USB adapter for the hard drive you could clone the drive with pfSense up - the resultant disk will almost certainly report some errors from fsck on startup and you will have to tweak the mount point if the cloned drive doesn't get the same device name as the original drive.



  • @stephenw10

    Just tried the burned cds AND the thumbdrive on a few other devices, including my macbook. They all boot just fine.
    Now i am considering swapping that cd-drive. I just have to find another ancient device that still uses those.
    Sadly i have no laptops around.

    @wallabybob

    The working PE1750 machine is the backbone firewall of my network here.
    So downtime is literally the last possible option. I might have to do it around 2-3 am-
    But even then, the system is running on 3 HDDs. Two of them in a raid array.
    So the restoring and mounting will be a headache.

    I'm gonna start fiddling around some more with it.
    Let's see if something changes.



  • Weeeeell, since the original PE machine was running on a three HDD raid array,
    i ended up taking one of those and placing it into the second machine.

    Booted them both so they rebuild the arrays.
    Now they're fine.

    Thank you all for your suggestions :)


Locked