Ral0: need multicast update callback



  • Hi:everyone
    I am a Newbie to the forum and looking for some help.

    I am loading pfsense 2.0.1  and I can not get the wireless to work.
    Everything loads find. I do the basic setup and change to HTTP://
    login to complete setup. When I setup the wireless as an access point ( WPA) the
    system locks.

    Looking at the council I get the following message:
              ral0: need multicast update callback
              ral0: need multicast update callback
              ral0: need multicast update callback

    If you hit the ENTER key in the console you can make it get to the WPA setup, but you have to have the shell running.
    WPA will total;y lock the system up though.
    I have reinstalled several times with the same results.

    System: Compaq EVO D500, Pen(r)4 1800 MHz. with 1 GB memory
    Card: Ralink Tech. RT2561S

    Looking on the web there seems to be a lot of conversation on this error.
    Does pfsense have a fix for this problem.

    I am building this firewall for our local fire department. I have a
    pfsense box there now that does not have wireless and it has not given any
    trouble. We need the wireless connection for their meeting room, so the
    lectures can connect their laptops when they give demonstrations.

    My Linux skills are more the beginner level or RUSTY. I can do almost any thing
    that has instructions available to do. I have Linux background but do not dive into the command line often enough to be efficient.
    Bob



  • You will need to look at the freebsd 8.1 hardware support. http://www.freebsd.org/releases/8.1R/hardware.html#WLAN

    Anything other than an Athros based chipset does not seem to work out very well. Most are set to be used as a WAN, but the Athros based WLAN cards work best for APs.



  • May work fine with the newer driver in FreeBSD 8.3, in 2.1.  snapshots.pfsense.org



  • Thanks for the help.
    I have downloaded the newer version and will try that.
    Will let you know how it works with Ralink rt2561S
    Bob :)



  • Tried the newer version 2.1-8.3 iso
    Got o configuring WIRELESS interface and it hung.

    I am going to try to get 2.01 R to work.

    Will let you know if I get it to work.
    Thanks, Bob



  • Got the firewall up.  The interface has to be named and rules set before interface can be activated.

    My friend and I worked on this for a couple hours to get working.

    I have firewall up for 3 days now testing before I deploy it.

    I have a config with passwords XXXXX out if there is a way to post it, I would like to know.

    Bob


Locked