Problems getting ipv6 address



  • Rumours has it that my ISP (Telenor.no) has enabled ipv6 for their users, so naturally i wanted to give it a shot.. However, things are not looking too bright atm.

    I dont get a ipv6 address on my wan, but i dont know if there is some error related to this. My syslog sais :

    Jun 8 22:37:19	dhcp6c[44112]: client6_init: skip opening control port
    Jun 8 22:37:19	dhcp6c[44112]: client6_init: skip opening control port
    Jun 8 22:37:19	dhcp6c[44112]: client6_init: failed initialize control message authentication
    Jun 8 22:37:19	dhcp6c[44112]: client6_init: failed initialize control message authentication
    Jun 8 22:37:19	dhcp6c[44112]: dhcp6_ctl_authinit: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory
    Jun 8 22:37:19	dhcp6c[44112]: dhcp6_ctl_authinit: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory
    Jun 8 22:37:19	php: /interfaces.php: The command '/sbin/ifconfig xl0 inet6 defroute_rtadv' returned exit code '1', the output was 'ifconfig: defroute_rtadv: bad value'
    Jun 8 22:37:19	php: /interfaces.php: Accept router advertisements on interface xl0
    

    xl0 then being my interface.

    Is there something i have overlooked? Or some minor command i could do to solve/provide more info? :)

    C



  • If Telenor.no is using DHCP6 on the WAN, then yes that should spring to life at some point.

    The other messages are left over from  different methods we tried. I still need to remove the bogus accept router advertisement command.



  • Hmm.. could it be something else i have missed in my setup then? Do i need to open any special traffic inbound on the firewall side perhaps?

    I have enabled dhcpv6 on the wan interface, and i have made sure that the "allow ipv6" box is ticked under the advanced section. Ive also tried to set "DHCPv6 Prefix Delegation size" to none, 64 and different settings to no avail. Should i need anything more?

    Dashboard just reads : "pending" on wan_dhcp6.

    C



  • Yeah, in that case I don't think it is enabled for you yet.

    Do you even see a ipv6 autoconfigured address on the wan?



  • @databeestje:

    Do you even see a ipv6 autoconfigured address on the wan?

    Nope, my problem is not that i cant communicate via ipv6, but that i dont get one at all on the wan interface.

    Could be that whatever segment i am on from my ISP, ipv6 is just not enabled at all.

    Well.. some day :)

    C


Locked