SqStat error - Error (1): Cannot get data. HTTP/1.0 301 Moved Permanently



  • Hi guys.

    I have:
    PFsense: 2.0.1-RELEASE (i386) built on Mon Dec 12 17:53:52 EST 2011 FreeBSD 8.1-RELEASE-p6
    Squid: 2.7.9 pkg v.4.3.1
    SquidGuard: 1.4_2 pkg v.1.9.1
    LightSquid: 1.8.0 pkg v.2.32

    Everything is working fine, except when i go to Status –> Proxy report --> Proxy State i have the following error:

    SqStat error
    Error (1): Cannot get data. Server answered: HTTP/1.0 301 Moved Permanently

    What that's it mean?
    Tips to solve it, please?
    Any help will be apreciated
    Thanks in adavance



  • I can't still solve it  :(…........Anyone has a clue?



  • Pls show you squid$ config.



  • @dvserg:

    Pls show you squid$ config.

    The squid config is:

    
    # Do not edit manually !
    http_port 192.168.2.254:3128
    http_port 127.0.0.1:3128 transparent
    icp_port 0
    
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_directory /usr/local/etc/squid/errors/English
    icon_directory /usr/local/etc/squid/icons
    visible_hostname localhost
    cache_mgr admin@localhost
    access_log /var/squid/logs/access.log
    cache_log /var/squid/logs/cache.log
    cache_store_log none
    logfile_rotate 30
    shutdown_lifetime 3 seconds
    # Allow local network(s) on interface(s)
    acl localnet src  192.168.2.0/255.255.255.0
    uri_whitespace strip
    
    cache_mem 256 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy lru
    cache_replacement_policy lru
    cache_dir ufs /var/squid/cache 4000 4 256
    minimum_object_size 100 KB
    maximum_object_size 512000 KB
    offline_mode off
    
    # No redirector configured
    
    # Setup some default acls
    acl all src 0.0.0.0/0.0.0.0
    acl localhost src 127.0.0.1/255.255.255.255
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901  3128 1025-65535 
    acl sslports port 443 563  
    acl manager proto cache_object
    acl purge method PURGE
    acl connect method CONNECT
    acl dynamic urlpath_regex cgi-bin ?
    cache deny dynamic
    http_access allow manager localhost
    
    # Allow external cache managers
    acl ext_manager_1 src 127.0.0.1 
    http_access allow manager ext_manager_1
    acl ext_manager_2 src 192.168.2.254 
    http_access allow manager ext_manager_2
    acl ext_manager_3 src  
    http_access allow manager ext_manager_3
    
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    
    # Always allow localhost connections
    http_access allow localhost
    
    quick_abort_min 0 KB
    quick_abort_max 0 KB
    request_body_max_size 90000 KB
    reply_body_max_size 30720000 deny all
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_initial_bucket_level 100
    delay_access 1 allow all
    
    # Custom options
    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
    redirector_bypass on
    redirect_children 3
    # Setup allowed acls
    # Allow local network(s) on interface(s)
    http_access allow localnet
    # Default block all to be sure
    http_access deny all
    
    


  • Possible show screenshot SQStat error ?



  • @dvserg:

    Possible show screenshot SQStat error ?

    Here it goes:



  • Thx.
    Please check whether sqstat work, if you disable squid transparent mode?



  • @dvserg:

    Thx.
    Please check whether sqstat work, if you disable squid transparent mode?

    It doesn't work, same error without transparent mode



  • Anyone has a clue about what log files to check?


Log in to reply