Strange error message in Dashboard…



  • I got this error message after a page reload, and since it doesn't go away, even persists through a software update…
    Any idea what's that from?

    The part that's scribbled out black in the error message is the host's IPv4 address.
    I now accessed the host by its name, and it goes away. Why would I get a referrer error when I simply access the box with it's IP address?

    ![Screen Shot 2012-06-12 at 06.03.06.png](/public/imported_attachments/1/Screen Shot 2012-06-12 at 06.03.06.png)
    ![Screen Shot 2012-06-12 at 06.03.06.png_thumb](/public/imported_attachments/1/Screen Shot 2012-06-12 at 06.03.06.png_thumb)


  • Rebel Alliance Developer Netgate

    Looks like something odd was happening in the background.

    Line 713 is looping over $config['interfaces'], if it can't foreach that, your config is blank/empty somehow.

    After getting an error like that, ensure that you completely clear your browser cache and then see if you can reproduce it.

    You shouldn't get a referer error when accessing by IP, but if something bombed elsewhere that made it not able to locate the info it needs to do the check, it might fail anyhow.



  • Well, a few hours later the file system was 109% full, and then the box died.
    I think I blew a CF card.

    Back to my old firewall until I reinstall and restore the configuration ;(



  • you may try new version . such as : 2.1-BETA0 (i386)
    built on Wed Jun 13 20:47:34 EDT 2012



  • After a re-install on a new SSD these issues are (at least for now) gone.
    There are some other issues, though, see separate posts.


Locked