[SOLVED]Vlan config/setup

  • Hello everyone.

    I have recently started to play around with vlans in my pfsense setup. But i have to admit that i am quite lost. I have googled and red pages and explainations and i still dont get it all the way.

    My current setup is Pfsense 2.01 and works like expected. The problem here is that i dont know how to solve my problem below. I was hoping that someone could point me in the right way.

    1 wan interface
    1 lan interface
    3 vlan  - vlan 20 -vlan 30 -vlan 40

    I have a switch configured and connected to my vlan interface nic and i have configured a new vlan 20 in the switch. The port that pfsense box is connected to is tagged and the other ports are untagged. This works like expected. I recieve ip from my vlan 20 interface and all is fine.

    Now i want to add a multi SSID access point and on this one i have created a vlan for each SSID accordning to my setup in pfsense. And now comes the tricky part i cant get to understand. I have to connect the accesspoint to my switch but how should it be configured to allow my vlans from the pfsense box to be passed through the switch and then to the accesspoint? I thought that i could create a new vlan, say 100 on the switch and tag the port of pfsense and then untag the port the accesspoint is connected to. But this is probably all wrong i here iam stucked.

    Is it not a possible solution? If i connect the access point straight to my pfsense nic then it probably works like expected but i still want the switch with the wired connections connected.


  • Simply connect that AP to Trunk port of the switch

  • Ok.

    Should the trunk port be a part of the vlans or should it be a standalone one? If i take a look at My switch config i can assign any port as trunk. Could it be right?

  • The data coming from the access points are already tagged, so you just need to tell the switch to allow all these vlans on a port, i.e a trunk port. If your access point supports it, remember to put the management lan in an appropriate vlan so you can still get to it.

  • Thanks for the answers and help. I read up about the trunk setting and now its working as well =)


  • Great to hear.

    You can edit first post and add to subject [SOLVED]

Log in to reply