Installation over pxe; problem with init [solved]



  • I try to install the pfSense-1.2-BETA-1 over PXE. But I get the following message:

    
    Trying to mount root from CD9660:/dev/iso9660/pfSense
    Trying to mount root from:
    NFS ROOT: 192.168.0.2:/pxeroot
    re1: link state change to DOWN
    re1: link state change to UP
    exec /sbin/init: error 13
    init: not found in path /sbin/init:/sbin/oinit:/sbin/init.bak:/rescue/init:/stand/sysinstall
    panic: no init
    cpuid = 0
    Uptime: 5s
    Cannot dump. No dump device defined.
    
    

    I have read, that error 13 is EACCES and means, that the file isn't executable. But I don't know where I can set it executable :/

    I do the installation with Tftpd32 3.03 (pxelinux) and AllegroNFSd 1.1.4 on Windows XP SP2.
    The installation of FreeBSD 6.2 works fine.
    I tried, various new snapshots, but all gave me the same error. Using of older versions are impossible, because FreeBSD 6.1 has no driver for my NIC.

    I ponder to do it like FreeBSD with an RAM disk (mfsroot.gz in vfs.root.mountfrom="ufs:/dev/md0c"), but I don't know how to make a RAM disk.

    I would be gratefully if someone has good information/documentations, which help me to set it executable or make a RAM disk.
    I would be more gratefully if someone can help me direct to install it over PXE.



  • Now I have tried out of a FreeBSD. This works, but I get a Network Interface mismatch and I have to select the Interfaces, but than it hangs at Configuring LAN interface.

    my dhcpd.conf

    
    authoritative;
    
    ddns-update-style		none;
    
    #use-host-decl-names		on;
    option subnet-mask		255.255.255.0;
    option broadcast-address	192.168.0.255;
    option root-path		"192.168.0.13:/usr/local/tftpboot/pfsense/";
    filename			"pfsense/boot/pxeboot";
    
    subnet 192.168.0.0 netmask 255.255.255.0 {
    #	range 			192.168.0.23 192.168.0.42;
    }
    
    host pxe {
    	hardware ethernet	52:54:00:12:34:56;
    	fixed-address 		192.168.0.13;
    }
    
    host pfSense {
    	hardware ethernet	00:30:18:b0:c4:b7;	
    	fixed-address		192.168.0.14;
    	next-server		192.168.0.13;
    	option routers		192.168.0.13;
    }
    
    

    on 192.168.0.13 runs the FreeBSD and on 192.168.0.14 pfSense

    and in my /usr/local/tftpboot/pfsense/cf/conf/config.xml

    
    	 <interfaces><lan><if>re0</if>
    			<ipaddr>192.168.0.14</ipaddr>
    			<subnet>24</subnet>
    			<media></media>
    			<mediaopt></mediaopt>
    			<bandwidth>1000</bandwidth>
    			<bandwidthtype>Mb</bandwidthtype></lan></interfaces> 
    

    see anyone a failure?



  • Now I have tried the installation via the normal live-cd and it still hangs at "Configuring LAN interface…"

    Has anybody a clue where the problem is?



  • Sounds like a NIC issue.  Make sure there are no shared IRQ's.  Also, re nics are not that great.  Consider changing them out for Intel branded NICS.



  • Ok now it works. I'm not sure what the problem was, because I don't want to test more. It seems a combinations of some things. Furthermore I had a problem caused by a to fast running RAM, because of a SPD failure. Now all is fine :)

    In the PXE-Boot settings were also a failure. This works now too, but I tested it only with a VM, so the setup is still with BETA-1.

    If there is interest, I could provide a Qemu-Image with a FreeBSD as base to install pfSense via PXE.


Log in to reply