NAT Reflection



  • Hi all

    I’ve an problem with configuring RAN Reflection on pfsense 2.0.1

    This is my setup:

    xDSL modem/router:
    public: xxx.xxx.xxx.xxx
    LAN: 192.168.0.1
          to
    WAN pfsense: 192.168.0.2
    LAN pfsense: 192.168.1.1 (dhcp on)

    En these are my settings in pfsense of the NAT Reflection:

    On the NAT Port Forward setting i’ve set NAT reflection ”Enable”

    On the advanced tab i’ve unchecked the “Disable NAT reflection for port forwards"

    When I try to connect my forwarded port from a PC on the LAN network to my publicaddress “xxx.xxx.xxx.xxx” I can’t get any connection. While I doing this from another publicaddress there is no problem.
    Someone an idee wath can help me to find the solution?

    Regards



  • Your public address is on your DSL modem/router.
    Your modem/router would have to be able to perform NAT reflection (which it obviously can't).

    Can you put your modem/router into transparent mode so you have your public IP on the pfSense iteself?
    Did you take a look at this page: http://doc.pfsense.org/index.php/Why_can't_I_access_forwarded_ports_on_my_WAN_IP_from_my_LAN/OPTx_networks%3F
    If you can't put the public IP on the pfSense, i suggest you use option 2.



  • I’ve tried it several times without any succes. But know I did it again and it works. I’ve forgot to use ‘Host’ in my connection.
    Thanks for your reply.



  • @fellesnelle:

    I’ve tried it several times without any succes. But know I did it again and it works. I’ve forgot to use ‘Host’ in my connection.
    Thanks for your reply.

    I have the same problem, can you explain me how did you fixed it???
    Thanks!!


Log in to reply