Menus do dansguardian e squid sumindo….e outras coisas mais. :(



  • Boa tarde a todos.

    Estou com o problema descrito no post… já desinstalei os 2 pacotes por diversas vezes e ainda sim persiste o problema... no gerenciador basta que eu reinstale apenas a GUI que funciona...
    O estranho é que o pacote que está instalado (no caso o squid) consta como disponível e não como instalado... apesar de tudo, tanto o squid quanto o dans funcionam normalmente, apenas
    não os vejo mais seus menus em services...

    No Dansguardian, grupos recém criados somem e as categorias das blacklists aparecem quando querem.... No menu blacklist, já configurei diversas vezes outras urls e as frequencias, mas, sempre que volto
    está como antes.
    Estou perdido... não sei o que pode estar acontecendo.... já troquei até de máquinas (era uma HP workstation 8800 - xeon biprocessado com 4GB) mas nada adiantou...
    Vou tentar agora gravar outra mídia (com a versão x64), testar com outro HD..... :(

    []s



  • Muito estranho mesmo.

    o que você tem nos logs do sistema?

    Alguma recuperação automatica de xml?

    Nunca vi isso acontecer em nenhuma das minhas instalações.



  • @marcelloc:

    o que você tem nos logs do sistema? Alguma recuperação automatica de xml?

    Marcello, nos logs em system logs não aparece nada… como vejo se está acontecendo alguma recuperação automática???
    Acabei de instalar um sistema novo aqui... e mesmo mostrando em system package maneger o dansguardian , o menu dele não apareceu.
    cliquei em reinstalar novamente, e aí o danado do menu apareceu...
    Vc disse em outros posts que o dansguardian instala o squid stable como padrão, mas não vejo no menu services o squid apenas o dansguardian.
    Devo instala-lo manualmente (pelo package) certo??? e no caso de instalar o squid3, devo instalar primeiro o 2 e depois o 3????

    []s



  • Pessoal …

    Outra coisa que notei no Dansguardian...
    Ainda não baixei nenhuma blacklist.. apenas criei novas listas para testes.
    lista diretoria - unfiltered - e apliquei ao grupo diretoria (que tem o usuario teste1 cadastrado)
    lista colaboradores_geral - filtered (coloquei em banned sites apenas 2 sites - caixa e baboo) e apliquei ao grupo colaboradores_geral. (que tem o usuario teste2 cadastrado)
    lista colaboradores_produtividade - filtered (coloquei em banned site apenas 1 site - baboo) e apliquei ao grupo colaboradores_produtividade. (que tem o usuario teste3 cadastrado)

    abro o internet explorer, e usando o usuario teste3 ao ser bloqueado tentando acessar o site do baboo, a mensagem do dansguardian me diz qual categoria foi aplicada (banned sites)
    usando o usuario 2 ao ser bloqueado tentando acessar os sites do baboo e da caixa a pagina de bloqueio apenas mostra como categoria as palavras N/A... deveria ser igual ao usuario teste3 ....
    Notei que ao criar as listas, que apenas a lista colaboradores_produtividade replicou os textos explicativos em inglês dentro das caixas {config} sendo esta a única que me mostra a categoria aplicada na pagina de bloqueio.
    tentei criar mais listas, mas todas repetiram o mesmo erro, nenhuma possuia os textos explicativos e nenhuma delas, quando aplicadas tinham as categorias mostradas na pagina de bloqueio....

    []s

    []s



  • Instale o pacote squid 2 ou 3 depois de instalar o dansguardian.

    O código da interface gráfica carrega o arquivo padrão quando a configuração é salva em branco
    Posta alguns screenshots da configuração do dansguardian para eu entender melhor o que voce esta tentando fazer



  • @marcelloc:

    Instale o pacote squid 2 ou 3 depois de instalar o dansguardian.

    O código da interface gráfica carrega o arquivo padrão quando a configuração é salva em branco
    Posta alguns screenshots da configuração do dansguardian para eu entender melhor o que voce esta tentando fazer

    marcello..

    Segui a ordem que vc citou em outros posts… primeiro o dansguardian, depois o squid.... (no post que vc anunciou o dansguardian para o pfsense tinha essa dica)... Não devo mais segui-la então???

    consegui resolver o problema das listas... mas tive que seguir um padrao... primeiro crio a lista desejada e a salvo sem alterar qualquer campo... quando vou edita-lá os textos padroes estão preenchidos e a
    categoria da lista é então aplicada na página de bloqueio... Vou fazer um testo baixando uma blacklist e criando uma nova lista para ver o que acontece... posto aqui os resultados.

    Uma coisa que notei foi excluindo a lista pela interface gráfica, não exclui o arquivo em /usr/local/etc/dansguardian/lists... apenas manualmente consegui apagar... (é preciso reiniciar o serviço para apagar os arquivos???)

    []s

    ![lista 1.jpg](/public/imported_attachments/1/lista 1.jpg)
    ![lista 1.jpg_thumb](/public/imported_attachments/1/lista 1.jpg_thumb)







  • @sosmicro:

    Segui a ordem que vc citou em outros posts… primeiro o dansguardian, depois o squid.... (no post que vc anunciou o dansguardian para o pfsense tinha essa dica)... Não devo mais segui-la então???

    O dansguardian saiu antes do squid3, e na epoca não havia problema em um squid2 sobrescrever os binarios de outro squid2

    @sosmicro:

    consegui resolver o problema das listas… mas tive que seguir um padrao... primeiro crio a lista desejada e a salvo sem alterar qualquer campo... quando vou edita-lá os textos padroes estão preenchidos e a
    categoria da lista é então aplicada na página de bloqueio...

    É exatamente o que a descrição do campo diz…

    Leave empty to load dansguardian defaults

    @sosmicro:

    Uma coisa que notei foi excluindo a lista pela interface gráfica, não exclui o arquivo em /usr/local/etc/dansguardian/lists… apenas manualmente consegui apagar... (é preciso reiniciar o serviço para apagar os arquivos???)

    Pode ficar tranquilo, se não está na gui, o dansguardian não vai carregar.



  • @marcelloc:

    É exatamente o que a descrição do campo diz…

    Leave empty to load dansguardian defaults

    Marcello… vou fazer um mea culpa.... o problema não era no hardware ou software... era o peopleware... ;D ;D ;D ;D ;D ;D ;D
    apenas mais uma duvida quanto ao dansguardian... configurei para baixar e aplicar a blacklist (http://urlblacklist.com/cgi-bin/commercialdownload.pl?type=download&file=bigblacklist).Recriei as lista de acesso e relacionei aos grupos e estão funcionando... queria saber se tem como aparecer na pagina de bloqueado a categoria que gerou o bloqueio... antes de marcar qualquer categoria das blacklists estava aparecendo (como no screenshot)...

    []s



  • @sosmicro:

    queria saber se tem como aparecer na pagina de bloqueado a categoria que gerou o bloqueio… antes de marcar qualquer categoria das blacklists estava aparecendo (como no screenshot)...

    Normalmente só não aparece quando você muda o tipo do relatório na aba report ou na aba de grupos(não estou com um dansguardian aqui em casa para conferir).



  • @marcelloc:

    Normalmente só não aparece quando você muda o tipo do relatório na aba report ou na aba de grupos(não estou com um dansguardian aqui em casa para conferir).

    Marcello.

    conferi os tipos de relatórios e estão todos iguais… consigo reproduzir o erro da seguinte forma... crio uma nova lista (ex: lista3), salvo sem modificar nada, edito em seguida colocando em banned sites um endereço qualquer...atribuo esta lista a um grupo e testo... neste caso a pagina de bloqueio mostra a categoria (banned sites) do site bloqueado....
    Se volto a editar a lista3 marcando em banned qualquer das categorias da blacklist e salvo... da proxima vez que aparecer a pagina de bloqueado mas a categoria fica N/A....
    tentei criar uma lista deixando apenas as categorias de bancos liberadas e testei com o site da caixa por ex... só que aparece a pagina de bloqueado mas sem a categoria.. aí fico sem saber qual outra categoria
    deveria liberar para tal situação...

    []s



  • sosmicro,

    Não olhei o fonte do dansguardian, mas acredito que ao habilitar uma categoria, a lista de sites bloqueados aparecerá com n/a exatamente por não estar em nenhuma lista por categoria e sim no banned site em si.

    Marque as categorias e teste um site que está bloqueado na black list e não na sua banned list.

    att,
    Marcello Coutinho



  • @marcelloc:

    sosmicro,

    Não olhei o fonte do dansguardian, mas acredito que ao habilitar uma categoria, a lista de sites bloqueados aparecerá com n/a exatamente por não estar em nenhuma lista por categoria e sim no banned site em si.

    Marque as categorias e teste um site que está bloqueado na black list e não na sua banned list.

    att,
    Marcello Coutinho

    É exatamente isso que ocorre… para um site colocado na banned list a categoria é mostrada.... para um site marcado na blacklist isso não acontece...
    no site do dansguardian achei esta descrição...

    -CATEGORIES- is whatever you entered in #listcategory: "foobar" - often the name of the blacklist directory containing the file that contained the relevant block instruction.

    ou seja... deveria mostrar o nome do diretorio da blacklist correspondente ao bloqueio...



  • mais uma dúvida….

    tem como mostrar a página de bloqueio tbem para as páginas https ??? pra mim aparece apenas a pagina padrao de erro do IE (o ie nao  pode exibir a pagina da web).

    []s



  • @sosmicro:

    tem como mostrar a página de bloqueio tbem para as páginas https ??? pra mim aparece apenas a pagina padrao de erro do IE (o ie nao  pode exibir a pagina da web).

    Só depois da compilação do filtro ssl funcionar no dansguardian.

    Para enviar uma tela de erro para uma comunicação criptografada, você precisa estar no meio dela.

    att,
    Marcello Coutinho



  • @marcelloc:

    Só depois da compilação do filtro ssl funcionar no dansguardian.

    Para enviar uma tela de erro para uma comunicação criptografada, você precisa estar no meio dela.

    Bom dia marcello.

    Fiquei confuso.. isso é algo que consigo fazer ou é vc que está compilando essa feature??

    []s



  • Se você souber programar em c ou c++ então sua ajuda será muito bem vinda.

    Já tentei várias coisas mas sempre esbarro no mesmo ponto, o browser do cliente rejeita o certificado gerado pelo dansguardian.

    att,
    Marcello Coutinho


Log in to reply