Snort 2.9.2.3 pkg v. 2.2.1 Invalid keyword 'normalize_javascript'



  • I just upgraded the snort package to 2.9.2.3 pkg v. 2.2.1 and when I try to start snort on an interface it crashes with the following error:

    snort[4866]: FATAL ERROR: /usr/local/etc/snort/snort_41786_em2/snort.conf(168) => Invalid keyword 'normalize_javascript' for server configuration.
    

    If I disable the HTTP Preprocessor it starts fine. I currently have all the categories disabled. I am running 2.1-BETA0 (i386) built on Fri Jun 1 16:41:00 EDT 2012 FreeBSD 8.3-RELEASE-p2


Log in to reply