Packet Capture stopped working in the latest days builds. "invalid interface".



  • Hello,

    I was using the Packet Capture function just a few days ago working OK but now I get some strange "invalid interface" error
    regardless which "Interface" i'm using.

    I have also seen some strange entry in the dropdown Interface where it states "invalidinterface". (see screenshot PC2.jpg)
    I only have 3 interfaces defined.   WAN, LAN and a GIF-tunnel IPv6broker interface.  And no LAGG.  (see screenshot PC3.jpg)

    The only thing I could think of that has changed between when it was working and not working was defining OpenVPN Server entry
    and then later same day upgrading to newer build.

    I have tried to reboot the pfsense but still same problem.
    I have tried to remove the OpenVPN server entry but same problem.  (still have the "invalidinterface" in the dropdown and error when saving)
    The GIF-tunnel interface was defined earlier when Capture was working.  Worked both before and after defining GIF/Interface.

    Best regards
    Dan Lundqvist
    Stockholm, Sweden







  • I can confirm that I'm also having the same exact issue. sync'd this morning


  • Rebel Alliance Developer Netgate

    Should be OK now (just committed a fix)



  • Thanks for that.  I will test a new build and report back the result.

    //Danne



  • Packet Capture seems to work now after the fix.

    HOWEVER, I do still have a "invalidinterface" entry in the dropdownlist which I don't know what it is and how to get rid of !?

    //Danne


  • Rebel Alliance Developer Netgate

    That must have been there for testing the input validation. I just removed it.



  • Ok, thanks.


Log in to reply