Snort reinstall and new failing: libpcre.so.1: unsupported file layout



  • I did a reinstall of snort 2.9.2.3 pkg 2.2.1 on amd64 v 2.0.1 full install following the deinstall-rules mentioned here:

    http://forum.pfsense.org/index.php/topic,50540.msg269880.html#msg269880
    ```.
    
    But now i get this error:
    
    

    /libexec/ld-elf.so.1: /usr/local/lib/libpcre.so.1: unsupported file layout

    
    Any help appreciated! thx


  • What package "snort-dev" or "snort" ?

    Also what pfSense version do you use.

    Robert



  • snort, and pfsense 2.0.1


  • Rebel Alliance Developer Netgate

    Try this:

    uninstall, then from the shell:

    pkg_delete -f snort* pcre*

    Then try to reinstall.

    I checked the version of PCRE on the package server, and the one required by snort is built for amd64 so I'm not sure how you'd have pulled in the wrong one.



  • Running pfsense 2.01 amd64.
    I just upgraded my snort package to 2.9.2.3 pkg v. 2.5.1 and ran into the same problem.
    The system logs produced no error message, but trying to start snort from the command line revealed the same error message described in this thread.

    The issue was resolved by following jimp's instructions.

    Thank you.



  • @jimp:

    Try this:

    uninstall, then from the shell:

    pkg_delete -f snort* pcre*

    Then try to reinstall.

    I checked the version of PCRE on the package server, and the one required by snort is built for amd64 so I'm not sure how you'd have pulled in the wrong one.

    THANK YOU VERY MUCH!
    your instructions helped me to get Snort Running againĀ  :D
    I'm running Pfsense 2.0.1 X64 with Snort 2.9.2.3 Pkg 2.5.1
    Link to my post: http://forum.pfsense.org/index.php/topic,52854.0.html

    Thanks again


Locked