Sarg doesn't work



  • I installed this new package to check is capabilities, but something seems to be wrong on his code.
    It works in the "Real Time" option, but when you go to "View Report", an error message is generated:

    Error: Could not find report index file.Check and save sarg settings and try to force sarg schedule.

    Thanks.



  • Did you followed error instructions and checked sarg config and created a schedule to run sarg?

    All default options on sarg configuration has (yes) text. Select all default option, select reports you want and then force a schedule run



  • Maybe i have a misconfiguration somewhere, here are some screenshots, i am still having the same issue, do i need to edit some of the scripts after installation?
    Thanks.








  • Select all options with "yes" in description. You have no reports because I'd did not selected to create index file



  • Ok, i selected all options that display a "yes" as you suggested and doing it accordingly on what is written/suggested on the interface ("Sarg report options. Default values are in ( )
    If you select any option, it will be enabled on conf file.Use CTRL + click on this field"
    ), i then clicked on "Save" and went again on the "Schedule" menu, where i did force an update again and saved.
    I did repeat these action several times, but still nothing changed.
    Maybe Sarg is not sending any input to the "Conf" file or it's sending it to the wrong location???
    Thanks for your patience….




  • first point, use chrome or firefox to access pfsense 2.0.1 gui.

    Second try if browser change does not work is to run sarg on console/ssh to see what erros(if any) you are getting.

    sarg -x



  • Right, i did try with Chrome instead of IE, the only difference that i can notice is that the text area looks smaller, so we now have a smaller problem than before :D.
    Can you tell me how to access Sarg by ssh as you wrote? The "real time" option it's still working, it just doesn't create any of the nice looking graphic reports i have seen posted around



  • @EOC2611P:

    Can you tell me how to access Sarg by ssh as you wrote?

    • You can enable ssh on system advanced and use any ssh client(putty for example) to acess pfsense lan ip at port 22.

    • via ssh or via console, choose menu option 8.

    • run sarg or sarg -x and see what you get.



  • Thanks, here is what i get:




  • Select overwrite reports too on sarg config and try to run it again.

    if you still get this 'could not remove' error, delete the folder using

    rm -rf /usr/local/sarg-reports/*

    before trying another report generation.

    A good tip is to use suggested filter on schedule to limit the report to one day only.



  • Followed the new instructions, but the problem it's still there




  • There is no way to delete the file on PFSense ??




  • try to remove sarg-reports dir and then save sarg config again

    rm -rf /usr/local/sarg-reports

    before saving sarg config again, check if it was deleted

    ls /usr/local/sarg-repors

    are you using nanobsd or full install?



  • I am using a "Full Install", a whole pc totally dedicated at PFSense and nothing else running on it.
    After i insert the new code in Putty, there is no aknowledgement at all that something was deleted, nothing, however i can see that the folder is no longer there.
    The problem it's still there.
    I forced a new update, saved, re-forced, swapped a few things to see if it trigger something but nothing to do, it just recreated a new Sarg-Reports folder but it doesn't connect to the reports.
    The Real Time option it works fine.








  • After removing folder, you need to apply settings(not force update now) to sarg recreate the folder.

    After creating the folder, run sarg on console and check if it returns erros.



  • Ok, just to make sure i am doing everything right, when you write "apply" the new settings, you just mean to click on "save", right?

    Here is the result, it seems that Sarg it's still looking for something which is not there, also, everytime the new reports's folder is created, it also bring back to life the old reports's folder which starts from the 12 of April…






  • Maybe your report file is too large and sarg could not finish it's job.

    Include the -d date +%d/%m/%Y-date +%d/%m/%Y arg to sarg schedule to force a one day report.



  • Well, i don't know, that string is exactly a copy of what is there now.
    What i did try in between, is to re-install Sarg = didn't work.
    Remove and re-install Sarg = didn't work.
    Install all the other 2 packages (DansGuardian & SquidGuard) to see if it was just a compatibility problem with the one that is currently using(Squid) = didn't work.
    So, in light of this, i think it is actually taking too much time and efforts from both of us, thank you so much anyway for trying to solve my problem, i am giving up  :-[



  • EOC2611P,

    It maybe a missing detail, I have some sargs running on pfsense without issues.

    att,
    Marcello Coutinho



  • I just wanted to jump in and let people know if what my experience was;

    I installed Sarg and had the same issue.

    I tried all that was suggested in this thread and didn't find resolution.

    What seemed to work for me (and quite possibly is not the best solution) was to remove the Sarg package, connect to pfSense with WinSCP, navigate to usr/local and delete the sarg-reports directory.

    When I re installed the Sarg package, the reports worked fine.

    Just my 2c.


Locked