What happened to unbound?



  • Its now a long time i didn't see unbound in packages. Want to install it on amd64 pf 2.0.1.

    Any news here?



  • No one wants/can/will clear it up? Thats strange…





  • I just broke my 2.0.1 install and tried to start over. As far as I know, Unbound is still not even enabled in the GUI in 2.1. Can someone please restore the Unbound package?



  • For pfsense 2.0.0 and 2.0.1 this package should be available.
    For 2.1 it is not because of the question if it is integrated in 2.1 or not.

    You can ask in the thread I mentioned above if this package could be made available or not.



  • sorry, but on v2.0.1 on amd64 its not present! here a pic of the package-manager:




  • You are right.
    I misinterpreted the config:

    
     <package><name>Unbound</name>
    	<descr>Unbound is a validating, recursive, and caching DNS resolver. This package is a drop in replacement for Services: DNS Forwarder and also supports DNSSEC extensions. Once installed please configure the Unbound service by visiting Services: Unbound DNS.</descr>
    	<website>http://www.unbound.net/</website>
    	<category>Services</category>
    	<version>1.4.14_01</version>
    	<status>Alpha</status>
    	<maintainer>warren@decoy.co.za</maintainer>
    	<required_version>2.0</required_version>
    	<maximum_version>2.0.1</maximum_version>
    	<pkginfolink>http://doc.pfsense.org/index.php/Unbound_package</pkginfolink>
    	<config_file>http://www.pfsense.com/packages/config/unbound/unbound.xml</config_file>
    	<configurationfile>unbound.xml</configurationfile>
    	<depends_on_package_base_url>http://files.pfsense.org/packages/8/All/</depends_on_package_base_url>
    	<depends_on_package>unbound-1.4.14.tbz</depends_on_package>
    	<depends_on_package>ldns-1.6.11.tbz</depends_on_package>
    	<depends_on_package>expat-2.0.1_2.tbz</depends_on_package>
    	<depends_on_package>libevent-1.4.14b_2.tbz</depends_on_package>
    	<build_port_path>/usr/ports/dns/unbound/</build_port_path>
    	<build_port_path>/usr/ports/dns/ldns</build_port_path>
    	<build_port_path>/usr/ports/textproc/expat2</build_port_path>
    	<build_port_path>/usr/ports/devel/libevent2</build_port_path>
    	 <build_pbi><ports_before>dns/ldns textproc/expat2 devel/libevent2</ports_before>
    	<port>dns/unbound</port></build_pbi> 
    	<build_options>WITH_LIBEVENT=true WITH_THREADS=true WITHOUT_GOST=true WITHOUT_MAN=true</build_options>
    	 <logging><facilityname>unbound</facilityname>
    	<logfilename>unbound.log</logfilename>
    	<logtab>Unbound</logtab></logging> 
    	<after_install_info>Please visit Services: Unbound DNS to configure the Unbound DNS service. Remember you will need to disable Services: DNS Forwarder before starting Unbound. Also note if your DHCP server makes use of pfSense as the DNS server, then you will now need to add the IP address of the respective interface to the DNS servers field, in the DHCP server configuration page.</after_install_info></package> 
    
    

    I thought that

    <required_version>2.0</required_version>
    

    is the minimum version you need and that

    <maximum_version>2.0.1</maximum_version>
    

    is the maximum version you could have - so that it is available for pfsense 2.0.0 and 2.0.1

    In general it would be no problem to increase the version from 2.0.1 up to 2.1 but I do not know if this package is compatible with pfsense 2.0.1 or not.

    You could contact the maintainer of that package and ask if he can increase the version number.



  • pkg_config.8.xml.amd64 specifies for unbound:

    <maximum_version>2.0.1</maximum_version>
    

    But the version is actually 2.0.1-RELEASE



  • pkg_config.8.xml and pkg_config.8.xml.amd64 specify for unbound:

    <maximum_version>2.0.1</maximum_version>
    

    But the version is actually the string "2.0.1-RELEASE".
    Using the code that compares versions, I get this:

    var_dump(pfs_version_compare("","2.0.1-RELEASE","2.0.1-RELEASE"));
    int(0)
    var_dump(pfs_version_compare("","2.0.1-RELEASE","2.0.1"));
    int(1)
    

    When it compares, it thinks that "2.0.1-RELEASE" is a bigger version than "2.0.1".
    So unbound does not show up in the list.
    Other packages are listed as:

    <maximum_version>2.1</maximum_version>
    

    which has the effect of letting them run on "2.0.1-RELEASE" but not "2.1-BETA0".
    The easy fix is to change maximum_version to 2.1 - like for all the other packages.
    But I think it is strange to specify maximum_version 2.1 and have it mean in effect up to but not including any 2.1 variants. Comparing the text bit of the version string does not really work - "2.1-DEVELOPMENT" came before "2.1-BETA0" but they are alphabetically around the other way. Perhaps just the dotted numeric bit should be compared?



  • Perhaps someone is aguing with me because I changed the maximum version - but I just did it.

    @_igor_:
    Please post back if it is working or not. If it is NOT working we have to remove the change so that noone else is installing unbound and breaking its system.



  • Thats great! Its up and running! Thanks a lot for bringing back unbound!!! :)



  • @_igor_:

    Thats great! Its up and running! Thanks a lot for bringing back unbound!!! :)

    That sounds good.

    In general I do not change anything on packages or features I did not build myself or I do not maintain :)



  • Heck.  All this time I thought Unbound had been pulled.

    I had to figure out the old install url and have been using that to get Unbound in there.



  • I've read this thread, and saw the links to an impressive Google spreadsheet, and to a discussion that does not even mention the words "unbound" or "dns". Yet this thread is one of the few mentions of Unbound on pfSense forums in the last few months, according to the forum search engine.
    I keep hearing about integrating Unbound into 2.1, but it's nowhere to be found on 2.1 i386.

    I've been running Unbound on a Debian VM on my LAN.



  • The Unbound entry in pfsense-packages / pkg_config.8.xml has no mention of PBI, so it hasn't been integrated with 2.1 yet. Someone who cares needs to contact the package maintainer and see what they intend to do about it (look in Github in pkg_config.8.xml for the email address), then find a way forward.



  • @phil.davis:

    Someone who cares needs to contact the package maintainer and see what they intend to do about it (look in Github in pkg_config.8.xml for the email address), then find a way forward.

    It seemed to me wagonza was maintaining it.
    Profile: http://forum.pfsense.org/index.php?action=profile;u=24
    Unbound Thread: http://forum.pfsense.org/index.php/topic,41576.0.html

    If memory serves, he was having some persistent challenges with Unbound in 2.0.x and was focusing his effort on making it stable in 2.1.
    Didn't see much problem myself.  Unbound has been one of my most trouble-free packages.

    Note:
    To install Unbound on 2.0.1, I right-click© one of the install links (+) on the package installer page and change the install url.
    As example:

    https://192.168.1.1/pkg_mgr_install.php?id=Cron
    

    becomes

    https://192.168.1.1/pkg_mgr_install.php?id=Unbound
    

    I *think I did this on x64 as well, but it's been a while.



  • just try the normal url to your current running 2.1 pfsense.. and then add    /services_unbound.php


Log in to reply