Lan routing help needed



  • Hi all,

    Now, I am trying to see what the steps are to get traceroute to work across my 2 lan subnets. I have it setup currently with my wireless lan on one interface (OPT1) with a 192.168.3.0/24 and my lan on another interface (LAN) with a subnet of 192.168.1.0/24. Both can traceroute to the outside internet (WAN) but not to each other, everything else works though ping, intranet, etc.

    Now my reading so far has suggested I should be creating a static route, my question is then, do I need to create another gateway too? When I go to routing page and try to add one it defaults to the wan gateway, is that correct?

    Thanks in advance.



  • for starters: you don't need a static route!
    Pfsense automagically generates the routes for all interfaces configured on the device.
    Static routes should only be used for subnets located on a different router when there is no dynamic routing protocol used. (in pfsense >2.0 it even says so in the web-interface)

    Only thing you need to do is add a firewall rule to PASS traffic from one subnet to the other and (if needed) the other way around.
    You need to make sure these rules don't have a specific gateway specified and that they match before a possible rule that would send your packets to your isp's gateway.

    kind regards



  • Thanks for the reply, I miss understood the search results I did before posting and now understand routes better. I have tried all the of the pass rules I can think of without success, it still times out on all hops after the first hop. 192.168.3.1 or 192.168.1.1 depending on the network the traceroute was started on.



  • without more info we can't pinpoint the problem

    please show some screenshots of interface settings / firewall rules / routes / …



  • Oops, sorry to waste your time on this. The problems was I wasn't thinking about the firewalls on the computers I was trying to traceroute to. I didn't realize they were blocking the traceroute's ping. Thanks again for your help.


Log in to reply