Haproxy-full older version



  • Hi guys,

    I have been using haproxy-full 1.4.19 for some time as failover for mysql and is working really great!!

    I updated my pfSense to 2.0.1-RELEASE (amd64) and also the haproxy-full to 1.4.21 and now there are errors between the haproxy and the mysql server, which don't allow mysql client to connect through the haproxy

    Is there any special parameter/configuration for the "Advanced pass thru" that will solve this problem?
    or alternatively can I somehow install an older version (haproxy-full 1.4.19) of haproxy-full on pfSense 2.0.1?

    thanks in advance



  • @skipper:

    I updated my pfSense to 2.0.1-RELEASE (amd64) and also the haproxy-full to 1.4.21 and now there are errors between the haproxy and the mysql server, which don't allow mysql client to connect through the haproxy

    Any error messages on system logs or on console?

    @skipper:

    alternatively can I somehow install an older version (haproxy-full 1.4.19) of haproxy-full on pfSense 2.0.1?

    using pkg_add / pkg_delete you can remove current package and install an older version from

    http://files.pfsense.org/packages/8/All/

    or from my personal repo

    http://e-sac.siteseguro.ws/packages/8/All/

    remember to check if your system is i386 or amd64



  • Hi marcelloc,

    thanks for your fast reply!

    there was no error message on system logs.

    I removed haproxy-full 1.4.21 and downloaded 1.4.19 from your repo.
    I added the 1.4.19 package and it showed that was added successfully

    $ pkg_add /tmp/haproxy-1.4.19.tbz


    *  Congratulations!  Haproxy is now installed.  *


    However, I cannot see HAproxy under Services on pfSense menu neither on installed packages under System–>Packages.
    Does this way require a restart of pfSense in order to recognize the new installed package?

    ps.
    i am using 64bit but there was not any option for 32 or 64 package in the repository





  • thnx marcelloc,

    finally i used the haproxy-full 1.4.21
    I added on the Advanced pass thru of the frontend configuration: option mysql-check user haproxy
    and on the mysql server I created a user for haproxy

    seems to work fine so far

    regards


Log in to reply