Squid and DNS redirect in pf 2.0 how do you get google?



  • Hello I have a problem, I have squid setup and running (not transparent) and when someone types the wrong url like shop.mountaingear.com instead of buy.mountaingear.com squid throws the warning page.

    What I would like to do is have an incomplete url or wrong url then search Google or complete like Firefox does when it is not going through the proxy.

    Any help on this would be appreciated!



  • anyone have a direction for me?



  • I use OpenDNS, on errors their Guide page is displayed. First result shown for your example is the mountaingear webstore. Works as well with https sites, which I couldn’t redirect with squid.



  • Thanks for the reply, where do you set the dns up for squid?



  • I use OpenDNS for my main DNS servers as set up in System:General Setup, these are used by the DNS forwarder.
    I also have a LAN firewall rule to disallow DNS queries other than to the forwarder as I have a mildly restrictive policy set up with OpenDNS and I don’t want users overriding this by using another name server.
    However I see that it is posible to specify separate DNS servers for the proxy on the the Proxy Server:General page, near the bottom although I have not tried this.



  • Thanks for the reply, I will have to look into the DNS solution. I am using the DNS forwarder to automatically use the DNS from my ISP. I have set the DNS in the proxy as well. I still get a proxy error when I type in Google instead of google.com

    Error…

    The requested URL could not be retrieved

    While trying to retrieve the URL: http://google/

    The following error was encountered:

    Unable to determine IP address from host name for google

    The dnsserver returned:

    Name Error: The domain name does not exist.

    This means that:

    The cache was not able to resolve the hostname presented in the URL.
    Check if the address is correct.

    Your cache administrator is

    … End Error

    It is not that big of a deal but it would be nice if it just sent the request to Google on a bad spelling or out of date url. Oddly when I type in “Google website” it pulls up Google in a search.


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy