Backup Always Assumes Role of Master

  • I successfully have CARP working for the most part between two machines, but have a little problem.  No matter what, the backup server keeps assuming the role of "master" according to the CARP status page.  In addition, the primary server still claims to be the master of the WAN address.

    What's bugging me is that failover doesn't work, probably because of this.  Even when I disconnect the crossover between the two boxes, the same state between the two exist.  I also restarted the backup server during a download and the download completely stopped.

    I'm using 1.2 Beta from 5-04.  Can anyone provide me insight on this?  Thanks!

  • Wild guess.  Did you not change anything in Firewall -> Virtual IP -> CARP Settings?

    If so, update to a snapshot later today where this bug is now fixed or turn on pfSync in the CARP settings tab and click save.

  • Look at my reply :,4936.msg30001.html#msg30001

    Problem number 4. This might help.

  • Thanks for your help guys.  Everything now seems to be okay with the exception of the one CARP LAN IP I have.  For that IP, both machines list it as master.  In addition, both of them report:

    kernel: carp8: incorrect hash

    in their system logs (and I keep getting a LOT of these right after: last message repeated 600 times).  I checked that the password was okay.  Everything seems to be fine wrt that IP.  Any ideas on why it's giving this message on the two machines?

  • incorrect hash means the vhid passwords do not match.  Or vhids are not correctly aligned to be the same value between the IP's.

  • Thanks a lot for your help!  The passwords were correct.  What I ended up doing is deleting that CARP interface and recreating it.  Then I rebooted the backup machine.  When it came back up, it became backup for all the interfaces, including the one I had a problem with.  I made the master fail so that the IPs were handed over to the backup, and when the master came back up, the backup gave all the IPs back to the master without issue.  I hope this just stays this way and wasn't a one time thing…